ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-11974) Display label for the custom action
Date Thu, 12 Nov 2015 22:48:11 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-11974?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15003115#comment-15003115
] 

Hudson commented on AMBARI-11974:
---------------------------------

FAILURE: Integrated in Ambari-trunk-Commit #3823 (See [https://builds.apache.org/job/Ambari-trunk-Commit/3823/])
AMBARI-11974. Display label for the custom action. (Di Li via jaimin) (jaimin: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=8429a6a1d2f079f112929a0e21b34aac28c0c628])
* ambari-web/app/utils/helper.js
* ambari-web/test/views/main/host/details/host_component_view_test.js
* ambari-web/app/views/main/service/item.js
* ambari-web/app/views/main/host/details/host_component_view.js
* ambari-web/test/utils/helper_test.js


> Display label for the custom action
> -----------------------------------
>
>                 Key: AMBARI-11974
>                 URL: https://issues.apache.org/jira/browse/AMBARI-11974
>             Project: Ambari
>          Issue Type: Improvement
>          Components: ambari-server
>    Affects Versions: 2.1.0
>            Reporter: Dmitry Vasilenko
>            Assignee: Di Li
>              Labels: feature_custom_service
>             Fix For: 2.2.0
>
>         Attachments: AMBARI-11974.patch
>
>
> As currently implemented, the name of the function in the Python script is shown as it
is in the Ambari web UI for the custom command:
> {noformat}
> <customCommand>
>   <name>Remove_Sample_Data</name>
>   <commandScript>
>     <script>scripts/server.py</script>
>     <scriptType>PYTHON</scriptType>
>     <timeout>600</timeout>
>   </commandScript>
> </customCommand>
> {noformat}
> It would be more convenient to have a display label in addition  to the function name
so that the menu item would look like "Remove  Sample Data" instead of "Remove_Sample_Data".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message