ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitro Lisnichenko" <dlysniche...@hortonworks.com>
Subject Re: Review Request 40009: RU: SUSE new stack install failed
Date Fri, 06 Nov 2015 09:38:58 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/40009/#review105398
-----------------------------------------------------------



ambari-server/src/test/python/custom_actions/TestInstallPackages.py 
<https://reviews.apache.org/r/40009/#comment163985>

    Maybe add also a test that proves that package is not skipped if config enables it?


- Dmitro Lisnichenko


On Nov. 6, 2015, 10:41 a.m., Andrew Onischuk wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/40009/
> -----------------------------------------------------------
> 
> (Updated Nov. 6, 2015, 10:41 a.m.)
> 
> 
> Review request for Ambari and Dmitro Lisnichenko.
> 
> 
> Bugs: AMBARI-13761
>     https://issues.apache.org/jira/browse/AMBARI-13761
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> Installation of new stack failed on SuSE  
> Cluster: <http://172.22.113.76:8080> \- 48h - os-s11-3-thmgis-c102dalunsdgha
> -please stop when done.
> 
>     
>     
>     
>     No handlers could be found for logger "root"
>     2015-11-05 14:30:29,640 - Package Manager failed to install packages. Error: Execution
of '/usr/bin/zypper --quiet install --auto-agree-with-licenses --no-confirm --repo HDP-2.3.4.0-3148
--repo HDP-UTILS-2.3.4.0-3148 'hadooplzo_2_3_4_0_3148*'' returned 4. Problem: nothing provides
libjvm.so()(64bit) needed by hadooplzo_2_3_4_0_3148-native-0.6.0.2.3.4.0-3148.x86_64
>      Solution 1: do not install hadooplzo_2_3_4_0_3148-native-0.6.0.2.3.4.0-3148.x86_64
>      Solution 2: break hadooplzo_2_3_4_0_3148-native-0.6.0.2.3.4.0-3148.x86_64 by ignoring
some of its dependencies
>     
>     Choose from above solutions by number or cancel [1/2/c] (c): c
>     Traceback (most recent call last):
>       File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py",
line 307, in install_packages
>         skip_repos=[self.REPO_FILE_NAME_PREFIX + "*"] if OSCheck.is_redhat_family() else
[])
>       File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line
154, in __init__
>         self.env.run()
>       File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py",
line 156, in run
>         self.run_action(resource, action)
>       File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py",
line 119, in run_action
>         provider_action()
>       File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py",
line 45, in action_install
>         self.install_package(package_name, self.resource.use_repos, self.resource.skip_repos)
>       File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/zypper.py",
line 70, in install_package
>         shell.checked_call(cmd, sudo=True, logoutput=self.get_logoutput())
>       File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line
70, in inner
>         result = function(command, **kwargs)
>       File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line
92, in checked_call
>         tries=tries, try_sleep=try_sleep)
>       File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line
140, in _call_wrapper
>         result = _call(command, **kwargs_copy)
>       File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line
291, in _call
>         raise Fail(err_msg)
>     Fail: Execution of '/usr/bin/zypper --quiet install --auto-agree-with-licenses --no-confirm
--repo HDP-2.3.4.0-3148 --repo HDP-UTILS-2.3.4.0-3148 'hadooplzo_2_3_4_0_3148*'' returned
4. Problem: nothing provides libjvm.so()(64bit) needed by hadooplzo_2_3_4_0_3148-native-0.6.0.2.3.4.0-3148.x86_64
>      Solution 1: do not install hadooplzo_2_3_4_0_3148-native-0.6.0.2.3.4.0-3148.x86_64
>      Solution 2: break hadooplzo_2_3_4_0_3148-native-0.6.0.2.3.4.0-3148.x86_64 by ignoring
some of its dependencies
>     
>     Choose from above solutions by number or cancel [1/2/c] (c): c
>     Traceback (most recent call last):
>       File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py",
line 389, in <module>
>         InstallPackages().execute()
>       File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 218, in execute
>         method(env)
>       File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py",
line 152, in actionexecute
>         raise Fail("Failed to distribute repositories/install packages")
>     resource_management.core.exceptions.Fail: Failed to distribute repositories/install
packages
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/resources/custom_actions/scripts/install_packages.py dd43c8f

>   ambari-server/src/test/python/custom_actions/TestInstallPackages.py 7feef96 
> 
> Diff: https://reviews.apache.org/r/40009/diff/
> 
> 
> Testing
> -------
> 
> mvn clean test
> 
> 
> Thanks,
> 
> Andrew Onischuk
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message