ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-13458) Expose in the API whether downgrade is supported or not
Date Mon, 19 Oct 2015 15:53:05 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-13458?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14963498#comment-14963498
] 

Hudson commented on AMBARI-13458:
---------------------------------

FAILURE: Integrated in Ambari-trunk-Commit #3671 (See [https://builds.apache.org/job/Ambari-trunk-Commit/3671/])
AMBARI-13458. Expose in the API whether downgrade is supported or not (dlysnichenko: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=7bd1a2a3ba0198111d0447b1ff8ec8cf364e9fef])
* ambari-server/src/main/resources/Ambari-DDL-SQLServer-CREATE.sql
* ambari-server/src/main/resources/stacks/HDP/2.1/upgrades/nonrolling-upgrade-2.3.xml
* ambari-server/src/main/resources/Ambari-DDL-MySQL-CREATE.sql
* ambari-server/src/main/resources/Ambari-DDL-Oracle-CREATE.sql
* ambari-server/src/test/java/org/apache/ambari/server/orm/dao/UpgradeDAOTest.java
* ambari-server/src/main/resources/Ambari-DDL-Postgres-EMBEDDED-CREATE.sql
* ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog213Test.java
* ambari-server/src/main/java/org/apache/ambari/server/state/stack/UpgradePack.java
* ambari-server/src/main/java/org/apache/ambari/server/controller/internal/UpgradeResourceProvider.java
* ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog213.java
* ambari-server/src/main/resources/Ambari-DDL-Postgres-CREATE.sql
* ambari-server/src/main/resources/Ambari-DDL-SQLAnywhere-CREATE.sql
* ambari-server/src/main/java/org/apache/ambari/server/orm/entities/UpgradeEntity.java


> Expose in the API whether downgrade is supported or not
> -------------------------------------------------------
>
>                 Key: AMBARI-13458
>                 URL: https://issues.apache.org/jira/browse/AMBARI-13458
>             Project: Ambari
>          Issue Type: Story
>          Components: ambari-server
>    Affects Versions: 2.2.0
>            Reporter: Dmytro Grinenko
>            Assignee: Dmitry Lysnichenko
>            Priority: Blocker
>              Labels: branch:branch-dev-stop-all-upgrade
>             Fix For: 2.1.3
>
>
> Need API to expose whether a downgrade is supported or not, so that the UI can display
the downgrade button accordingly.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message