ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Di Li (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMBARI-11810) Rolling upgrade does not run pre-upgrade checks against non-HDP stack
Date Fri, 30 Oct 2015 14:58:27 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-11810?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Di Li resolved AMBARI-11810.
----------------------------
    Resolution: Fixed

> Rolling upgrade does not run pre-upgrade checks against non-HDP stack
> ---------------------------------------------------------------------
>
>                 Key: AMBARI-11810
>                 URL: https://issues.apache.org/jira/browse/AMBARI-11810
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.1.0
>            Reporter: Di Li
>            Assignee: Di Li
>             Fix For: 2.2.0
>
>         Attachments: AMBARI-11810.patch
>
>
> All the rolling upgrade pre-checks may still need to run against a non-HDP stack. Use
this JIRA to make the check runnable based on properties (rollingupgrade.stack, rollingupgrade.version)
set in the /etc/ambari-server/conf/ambari.properties. Still default to HDP and 2.2.4.2 if
the properties do not exist.
> org.apache.ambari.server.checks.AbstractCheckDescriptor compares stack against hardcoded
StackInfo "HDP-2.2". the stack name and version info can be externalized into the /etc/ambari-server/conf/ambar.properties
in order to support non-HDP stacks.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message