ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shashank Prabhakara <shash...@infoworks.io>
Subject Re: Ambari problems with python2.7
Date Thu, 08 Oct 2015 14:14:13 GMT
Yes, To be clear I want to avoid installing rpm-package(and any other) for
python2.7 for ambari.

I'm guessing ambari does not install python2.7, correct me if i'm wrong.
I want to force ambari to run on python2.6 again.

On Thu, Oct 8, 2015 at 9:56 AM, Greg Hill <greg.hill@rackspace.com> wrote:

> Are you on CentOS 6?  You'll have to leave Python 2.6 installed as well,
> since yum on that version only works with 2.6.  You just install python27
> as an alternate and point your other software at the alt-install.
>
> Greg
>
> On 10/8/15, 8:48 AM, "Shashank Prabhakara" <shashank@infoworks.io> wrote:
>
> >Hi all,
> >
> >I have a HDP installation managed by ambari and one of the software I need
> >use python 2.7 with these python packages - hdfs, avro, dataframe,
> >python-snappy among others.
> >
> >When I install python2.7 (compiled from code), pip and these packages,
> >ambari fails to start/restart components citing missing rpm package in
> >python.
> >
> >Anybody here can help with these issues - I want avoid setting up
> >python2.7
> >for ambari separately since this is only installed on one node.
> >
> >Shashank
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message