ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yusaku Sako" <yus...@hortonworks.com>
Subject Re: Review Request 39748: AMBARI-13495:JAVA_HOME setting is improper for Hive
Date Thu, 29 Oct 2015 08:06:06 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/39748/#review104403
-----------------------------------------------------------

Ship it!


Ship It!

- Yusaku Sako


On Oct. 29, 2015, 6:59 a.m., Chen Xin YU wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/39748/
> -----------------------------------------------------------
> 
> (Updated Oct. 29, 2015, 6:59 a.m.)
> 
> 
> Review request for Ambari.
> 
> 
> Bugs: AMBARI-13495
>     https://issues.apache.org/jira/browse/AMBARI-13495
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> Ambari would setup jdk with directory /usr/jdk64/* during ambari-server setup, and several
components will export java_home which ambari used in **-env.xml(such as oozie-env.xml), but
it's less in hive.
> 
> So hive maybe using another existing jdk, or less JAVA_HOME setting.
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/resources/common-services/HIVE/0.12.0.2.0/configuration/hive-env.xml
447993d 
> 
> Diff: https://reviews.apache.org/r/39748/diff/
> 
> 
> Testing
> -------
> 
> I tested on my local env, java home set corrected with the fix. UT testing are done,
no more failures.
> 
> 
> Thanks,
> 
> Chen Xin YU
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message