ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Swapan Shridhar" <sshrid...@hortonworks.com>
Subject Re: Review Request 39716: AMBARI-13596. Allow Falcon service to be upgraded and downgraded during Express Upgrade .
Date Wed, 28 Oct 2015 18:28:40 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/39716/
-----------------------------------------------------------

(Updated Oct. 28, 2015, 6:28 p.m.)


Review request for Ambari and Alejandro Fernandez.


Bugs: AMBARI-13596
    https://issues.apache.org/jira/browse/AMBARI-13596


Repository: ambari


Description
-------

AMBARI-13596. Allow Falcon service to be upgraded and downgraded during Express Upgrade in
the following paths : 

HDP 2.1->2.3
HDP 2.2->2.2.

HDP 2.2->2.3

HDP 2.3->2.3.

P.S. Downgrade path for 2.1->2.3 is not supported.


Diffs
-----

  ambari-server/src/main/resources/common-services/FALCON/0.5.0.2.1/package/scripts/falcon.py
e4edcff 
  ambari-server/src/main/resources/common-services/FALCON/0.5.0.2.1/package/scripts/falcon_client.py
dc970c8 
  ambari-server/src/main/resources/common-services/FALCON/0.5.0.2.1/package/scripts/falcon_server.py
3436e5b 

Diff: https://reviews.apache.org/r/39716/diff/


Testing
-------

Tested : 

HDP 2.1->2.3     - Success
HDP 2.3->2.3.*   - Success.

Currently, testing for : (Will update the test results by 10/28 afternoon).

HDP 2.2->2.2. 
HDP 2.2->2.3


Thanks,

Swapan Shridhar


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message