ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alejandro Fernandez" <afernan...@hortonworks.com>
Subject Re: Review Request 39599: [Preview] Express Upgrade: Hbase restart fails due to JAVA_HOME issues
Date Sun, 25 Oct 2015 06:32:39 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/39599/#review103940
-----------------------------------------------------------


Are the configs being applied correctly?

- Alejandro Fernandez


On Oct. 23, 2015, 3:32 p.m., Dmitro Lisnichenko wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/39599/
> -----------------------------------------------------------
> 
> (Updated Oct. 23, 2015, 3:32 p.m.)
> 
> 
> Review request for Ambari, Alejandro Fernandez and Dmytro Grinenko.
> 
> 
> Bugs: AMBARI-13547
>     https://issues.apache.org/jira/browse/AMBARI-13547
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> Looks like configure() was never called for HBASE after hdp-select. 
> As a result, hbase-env is missing for hbase at all after EU 2.1->2.3
> 
> ll /usr/hdp/2.3.0.0-2557/hbase/conf/
> total 0
> 
> I guessed it's because new-style start() with upgrade_type arg is not implemented yet
in HBASE script (I saw relevant legacy and new-style logic at script.py).
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/resources/common-services/HBASE/0.96.0.2.0/package/scripts/hbase_client.py
74cfde6 
>   ambari-server/src/main/resources/common-services/HBASE/0.96.0.2.0/package/scripts/hbase_master.py
56dde25 
>   ambari-server/src/main/resources/common-services/HBASE/0.96.0.2.0/package/scripts/hbase_regionserver.py
44feb0c 
>   ambari-server/src/main/resources/common-services/HBASE/0.96.0.2.0/package/scripts/phoenix_queryserver.py
edcf041 
>   ambari-server/src/main/resources/common-services/HBASE/0.96.0.2.0/package/scripts/setup_ranger_hbase.py
8f4a6d0 
> 
> Diff: https://reviews.apache.org/r/39599/diff/
> 
> 
> Testing
> -------
> 
> But current patch does not solve an issue. Maybe I'm missing something and it's a known
issue?
> 
> 
> Thanks,
> 
> Dmitro Lisnichenko
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message