ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Juanjo Marron" <jmar...@us.ibm.com>
Subject Re: Review Request 37626: AMBARI-12486 Enabling namenode HA fails when non default ports are used
Date Wed, 14 Oct 2015 20:28:32 GMT


> On Oct. 14, 2015, 7:04 p.m., Jaimin Jetly wrote:
> > Ship It!

Great! Thanks Jaimin.
I dont have privileges to commit it. Could someone ship it for me, please?


- Juanjo


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/37626/#review102689
-----------------------------------------------------------


On Sept. 23, 2015, 10:21 p.m., Juanjo  Marron wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/37626/
> -----------------------------------------------------------
> 
> (Updated Sept. 23, 2015, 10:21 p.m.)
> 
> 
> Review request for Ambari, Alejandro Fernandez, Jaimin Jetly, and Yusaku Sako.
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> Enabling HA code may not read correct properties.
> When HDFS and ZOOKEEPER ports are changed (different than default values ZK: 2181 and
HDFS: 8020,50070,50470), HA wizard menus is still showing the ones by default and HA namenode
fails with connection errors.
> Checked the source code for the Step 3 in namenode HA wizard (ambari-web/app/controllers/main/admin/highAvailability/nameNode/step3_controller.js)
> The node address is looked from the configuration but ports hardcoded instead of the
new once modified on the installation wizard, ex:
> ...
> this.setConfigInitialValue(config,'qjournal://' + journalNodeHosts[0] + ':8485;' + journalNodeHosts[1]
+ ':8485;' + journalNodeHosts[2] + ':8485/' + nameServiceId);
> this.setConfigInitialValue(config,zooKeeperHosts[0] + ':2181,' + zooKeeperHosts[1] +
':2181,' + zooKeeperHosts[2] + ':2181');
> ...
> This is a bug that should be fixed.
> 
> 
> Diffs
> -----
> 
>   ambari-web/app/controllers/main/admin/highAvailability/nameNode/step3_controller.js
cf2d971 
> 
> Diff: https://reviews.apache.org/r/37626/diff/
> 
> 
> Testing
> -------
> 
> Manual test on fresh installation
> 
> 
> Thanks,
> 
> Juanjo  Marron
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message