ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk" <aonis...@hortonworks.com>
Subject Re: Review Request 39235: Ambari does not install phoenix if one enables phoenix after cluster install is done
Date Mon, 12 Oct 2015 15:44:49 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/39235/
-----------------------------------------------------------

(Updated Oct. 12, 2015, 3:44 p.m.)


Review request for Ambari and Vitalyi Brodetskyi.


Bugs: AMBARI-13361
    https://issues.apache.org/jira/browse/AMBARI-13361


Repository: ambari


Description
-------

After enabling phoenix on a running cluster none of the region servers
started. I had to install the phoenix rpm on all the nodes and restart region
server to get it work.

Saw this on

    
    
    
    [root@pre-prod-poc-1 ~]# rpm -qa | grep ambari
    ambari-metrics-hadoop-sink-2.1.2-370.x86_64
    ambari-server-2.1.2-370.x86_64
    ambari-metrics-monitor-2.1.2-370.x86_64
    ambari-agent-2.1.2-370.x86_64
    

If the phoenix rpm is not installed region servers fail to start with class
not found exception.


Diffs (updated)
-----

  ambari-server/src/main/resources/common-services/HBASE/0.96.0.2.0/package/scripts/hbase.py
0d11e6c 
  ambari-server/src/main/resources/common-services/HBASE/0.96.0.2.0/package/scripts/params_linux.py
bf269d6 
  ambari-server/src/test/python/stacks/2.0.6/HBASE/test_hbase_regionserver.py dd477c1 
  ambari-server/src/test/python/stacks/2.0.6/configs/hbase-rs-2.2-phoenix.json PRE-CREATION


Diff: https://reviews.apache.org/r/39235/diff/


Testing
-------

mvn clean test


Thanks,

Andrew Onischuk


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message