ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitro Lisnichenko" <dlysniche...@hortonworks.com>
Subject Re: Review Request 38955: Hive Metastore start error after stack upgrade
Date Fri, 02 Oct 2015 14:41:58 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38955/
-----------------------------------------------------------

(Updated Oct. 2, 2015, 2:41 p.m.)


Review request for Ambari and Andrew Onischuk.


Bugs: AMBARI-13298
    https://issues.apache.org/jira/browse/AMBARI-13298


Repository: ambari


Description (updated)
-------

Observed after manual stack upgrade from 2.1.15 to 2.3.2 (Ambari upgraded from 1.6.1 to 2.1.2
beforehand)
 

And observed that while trying to start Hive service – it failed with below error:
 
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/config_dictionary.py",
line 81, in __getattr__
    raise Fail("Configuration parameter '" + self.name + "' was not found in configurations
dictionary!")
resource_management.core.exceptions.Fail: Configuration parameter 'hive.heapsize' was not
found in configurations dictionary!


Diffs
-----

  ambari-server/src/main/resources/upgrade/catalog/UpgradeCatalog_2.1_to_2.3.json 422b86b

  ambari-server/src/main/resources/upgrade/catalog/UpgradeCatalog_2.2_to_2.3.json 88772f9


Diff: https://reviews.apache.org/r/38955/diff/


Testing
-------

mvn clean test


Thanks,

Dmitro Lisnichenko


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message