ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (AMBARI-13229) When non-supported version of python is set as default, Ambari fails in multiple places
Date Fri, 25 Sep 2015 19:51:04 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-13229?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Hurley reopened AMBARI-13229:
--------------------------------------

> When non-supported version of python is set as default, Ambari fails in multiple places
> ---------------------------------------------------------------------------------------
>
>                 Key: AMBARI-13229
>                 URL: https://issues.apache.org/jira/browse/AMBARI-13229
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 2.2.0
>
>
> We had an issue where the root user's ~/.bashrc file had Python 3 in the PATH.
> We blindly tried to execute tasks and hdp-select blew up with a syntax issue.
> The vast majority of our tasks will fail with python 3 and as users start to
> more heavily adopt newer version of python for data science tasks there is
> risk that they will leak into being used by our user accounts, specifically
> root for root agents, and the non-root user for non-root agents.  
> I would propose that we check the version of python before attempting to start
> the ambari-agent, and fail with a non-zero exit code if we detect a non-
> compliant version.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message