ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMBARI-12961) Need a robust check for the existence of a package
Date Tue, 01 Sep 2015 14:46:45 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-12961?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Onischuk resolved AMBARI-12961.
--------------------------------------
    Resolution: Fixed

Committed to trunk

> Need a robust check for the existence of a package
> --------------------------------------------------
>
>                 Key: AMBARI-12961
>                 URL: https://issues.apache.org/jira/browse/AMBARI-12961
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 2.1.2
>
>
> There is a problem in the way Ambari checks for existence of packages to skip
> calls to install.
> The string used to install usually has some wild-cards e.g. `zookeeper_2_2_*`.
> If install is called using this string, it will pull in all packages that
> satisfy the condition.
>   * zookeeper_2_2_6_0_2800-server-3.4.6.2.2.6.0-2800
>   * zookeeper_2_2_6_0_2800-3.4.6.2.2.6.0-2800
> However, if "hadoop_2_2*" is installed first then it only pulls in
> zookeeper_2_2_6_0_2800-3.4.6.2.2.6.0-2800. Existence of this package satisfies
> the check if `zookeeper_2_2_*` is installed and thus
> `zookeeper_2_2_6_0_2800-server-3.4.6.2.2.6.0-2800` does not get installed.
> This resulted in <https://issues.apache.org/jira/browse/AMBARI-12874> where
> "hdp-select set zookeeper-server VERSION" is not called as
> zookeeper_2_2_6_0_2800-server-3.4.6.2.2.6.0-2800 never got installed.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message