ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-12771) Adding a CustomCommands causes Components are not being displayed in Host view
Date Fri, 04 Sep 2015 00:28:46 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-12771?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14730099#comment-14730099
] 

Hudson commented on AMBARI-12771:
---------------------------------

SUCCESS: Integrated in Ambari-branch-2.1 #476 (See [https://builds.apache.org/job/Ambari-branch-2.1/476/])
AMBARI-12771. Adding a CustomCommands causes Components are not being displayed in Host view.
(Shantanu Mundkur and Jaimin Jetly) (jaimin: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=842e221a62469cd87de4bb4501638fba640ad9cd)
* ambari-web/test/views/main/host/details/host_component_view_test.js
* ambari-web/app/views/main/host/details/host_component_view.js


> Adding a CustomCommands causes Components are not being displayed in Host view
> ------------------------------------------------------------------------------
>
>                 Key: AMBARI-12771
>                 URL: https://issues.apache.org/jira/browse/AMBARI-12771
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-web
>    Affects Versions: 2.1.0
>         Environment: RedHat Linux 6.5 x86_64
> Hotonworks 2.3 distribution
>            Reporter: Mahesh Kurapati
>            Assignee: Shantanu Mundkur
>              Labels: feature_custom_service
>             Fix For: 2.1.2
>
>         Attachments: AMBARI-12771_branch-2.1.0.patch, AMBARI-12771_branch-2.1.patch.2
>
>
> We are trying to add a CustomCommands to our service in HDP2.3 stack, but once  CustomCommands
added and restart Ambari in host view we can't see any components. This was working fine in
HDP2.2(Ambari-2.0.1).
> To reproduce follow below steps:
>    1. As per the Amabri desgin document https://cwiki.apache.org/confluence/pages/viewpage.action?pageId=38571133,
we tried to add a TESTSERVICE service like below which contains customCommands in metainfo.xml:
> <?xml version="1.0"?>
> <metainfo>
>   <schemaVersion>2.0</schemaVersion>
>   <services>
>     <service>
>       <name>TESTSERVICE</name>
>       <displayName>Test Service</displayName>      
>       <version>1.0.0.0</version>
>       <components>
>        <component>
>           <name>TEST_COMPONENT</name>
>           <displayName>Analytic Metastore</displayName>
>           <category>MASTER</category>
>           <cardinality>1</cardinality>
>           <clientsToUpdateConfigs></clientsToUpdateConfigs>
>           
>           <commandScript>
>             <script>scripts/script.py</script>
>             <scriptType>PYTHON</scriptType>
>           </commandScript>
>           <customCommands>
>             <customCommand>
>               <name>CustonAction</name>
>               <commandScript>
>                 <script>scripts/script.py</script>
>                 <scriptType>PYTHON</scriptType>
>                 <timeout>600</timeout>
>               </commandScript>
>             </customCommand>
>           </customCommands>
>         </component>        
>       </components>
>     </service>
>   </services>
> </metainfo>
>  2. restart Ambari server
>  3. Add service TESTSERVICE to any host
>  4. goto host view and see all the components not showed.
>  5. Also Service actions popup menu doesn't show this CustomAction.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message