ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vitalyi Brodetskyi" <vbrodets...@hortonworks.com>
Subject Re: Review Request 38163: Need more informative error message on set-current
Date Tue, 08 Sep 2015 08:43:44 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38163/
-----------------------------------------------------------

(Updated Вер. 8, 2015, 8:43 до полудня)


Review request for Ambari, Andrew Onischuk, Dmitro Lisnichenko, and Dmytro Sen.


Bugs: AMBARI-13028
    https://issues.apache.org/jira/browse/AMBARI-13028


Repository: ambari


Description
-------

When a user performances a manual upgrade (2.2 -> 2.3 or maint), they have to run set-current
at the end and provide cluster name and version display name.

If they incorrectly enter the cluster name, the error looks like this:

{code}
ambari-server set-current --cluster-name=os-rhel6-upgrade-t2-allservices --version-display-name=HDP-2.2.8.0
Using python  /usr/bin/python2.6
Setting current version...
Enter Ambari Admin login: admin
Enter Ambari Admin password:
ERROR: Exiting with exit code 1.
REASON: Error during setting current version. Http status code - 500.
 {
  "status" : 500,
  "message" : "org.apache.ambari.server.controller.spi.SystemException: Can not perform request"
}
{code}

This error should be a lot more informative to tell the user the cluster was not found, that
they should provide the cluster name and to double-check their command.


Diffs (updated)
-----

  ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ClusterStackVersionResourceProvider.java
be0af16 

Diff: https://reviews.apache.org/r/38163/diff/


Testing
-------

mvn clean test


Thanks,

Vitalyi Brodetskyi


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message