ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Di Li" <d...@ca.ibm.com>
Subject Re: Possible Ambari 2.1 rollingupgrade/downgrade defect when using configuration groups?
Date Tue, 01 Sep 2015 17:29:01 GMT
Hello Alejandro,

Yes, I have created JIRA AMBARI-12949 for the issue.

https://issues.apache.org/jira/browse/AMBARI-12949

Thank you.

Di Li
InfoSphere BigInsights
IBM Ottawa Lab Palladium Campus
Email: dili@ca.ibm.com
Phone: 613-270-4883, Tie-line:315-4883



From:   Alejandro Fernandez <afernandez@hortonworks.com>
To:     Ambari <dev@ambari.apache.org>, Di Li/Ottawa/IBM@IBMCA
Cc:     Tuong Truong <tctruong@us.ibm.com>, Tim Thorpe/Ottawa/IBM@IBMCA
Date:   09/01/2015 13:26
Subject:        Re: Possible Ambari 2.1 rollingupgrade/downgrade defect 
when using configuration groups?



Hi Di,

This sounds like a backend bug during Downgrade and reverting to the
original configs. Can you go ahead and create a Jira on Apache?

Thanks,
Alejandro

On 8/31/15, 1:09 PM, "Di Li" <dili@ca.ibm.com> wrote:

>Hello
>
>Could someone please help to verify whether I have hit an rolling
>upgrade/downgrade defect related to the configuration group?
>
>Details:
>I have a 4 node HDP 2.2 cluster where I created a configuration group to
>apply customized oozie_heap_size to the Oozie server and one of the Oozie
>client. I was able to rolling upgrade the cluster to HDP 2.3, but when I
>clicked Downgrade button on the Finalize step. The Ambari UI immediately
>threw error message "500 status code received on POST method for API:
>/api/vi/clusters/mycluster/upgrades"
>
>Checking the Ambari server log, it reported a nullpointer error when
>trying to load the designed configurations
>Aug 30, 2015 11:01:07 PM com.sun.jersey.spi.container.ContainerResponse
>mapMappableContainerException
>SEVERE: The RuntimeException could not be mapped to a response,
>re-throwing to the HTTP container
>java.lang.NullPointerException
>        at 
>org.apache.ambari.server.state.host.HostImpl.getDesiredHostConfigs(
>HostImpl.java:1349)
>
>Digging around in the database, I saw that the oozie-env (where I had a
>configuration group) had no version_tag set with "selected" as 1.
>Manually setting the version1 row to have selected = 1, restart server
>and 
>then I was able to run downgrade.
>
>ambari=> select * from clusterconfigmapping  where type_name =
>'oozie-env';
> cluster_id | type_name |     version_tag      | create_timestamp |
>selected |   user_name
>------------+-----------+----------------------+------------------+-------
>---+----------------
>          2 | oozie-env | version1             |    1441033897383 | 0 |
>admin
>          2 | oozie-env | version1441037586550 |    1441037586592 | 0 |
>ambari-upgrade
>          2 | oozie-env | version1441039514060 |    1441039516239 | 0 |
>admin
>(3 rows)
>
>
>
>Thank you.
>
>Di Li
>
>





Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message