ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sumit Mohanty (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (AMBARI-12874) Unable to start Zookeeper Server after RPM is installed
Date Tue, 25 Aug 2015 21:41:45 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-12874?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14711997#comment-14711997
] 

Sumit Mohanty edited comment on AMBARI-12874 at 8/25/15 9:41 PM:
-----------------------------------------------------------------

Ambari does not install zookeeper-\*server package if zookeeper package is already installed.
zookeeper package may get installed as a dependency of hadoop-\*. The logic to check if packages
are installed will find zookeeper installed and then will not invoke installation.

As a solution Ambari can explicitly install zookeeper*-server.  

Manually tested the changes on a cluster with modified metainfo.xml.


was (Author: sumitmohanty):
Ambari does not install zookeeper-*server package if zookeeper package is already installed.
zookeeper package may get installed as a dependency of hadoop-*. The logic to check if packages
are installed will find zookeeper installed and then will not invoke installation.

As a solution Ambari can explicitly install zookeeper*-server.  

Manually tested the changes on a cluster with modified metainfo.xml.

> Unable to start Zookeeper Server after RPM is installed
> -------------------------------------------------------
>
>                 Key: AMBARI-12874
>                 URL: https://issues.apache.org/jira/browse/AMBARI-12874
>             Project: Ambari
>          Issue Type: Bug
>         Environment: SLES 11 SP3 Docker container where Ambari agent is deployed, HDP
2.2 stack, Ambari trunk codebase. RPMs are pulled from http://public-repo-1.hortonworks.com/HDP/suse11sp3/2.x/updates/2.2.6.0
>            Reporter: Vijay Srinivasaraghavan
>            Assignee: Sumit Mohanty
>         Attachments: AMBARI-12874.patch
>
>
> Looks like a fresh install of 2.2.6.0 does not have the issue.
>  
> If I uninstall zookeeper manually and then use Ambari to install Zoookeeper then I run
into the issue.
>  
> Looks like there is some pre-condition to the ZK rpm post-install script due to which
a re-install does not create zookeeper-server symlink. Interestingly zookeeper-client symlink
gets created properly.
>  
> On my machine - 
> rpm -qa | grep zook
> zookeeper_2_2_6_0_2800-3.4.6.2.2.6.0-2800
>  
> This is from the log when I removed:
> 2015-08-25 00:52:53 <1> samsuse-1(23137) [zypper:req++] SolverRequester.cc(remove):267
Marking for deletion: I__s_(5682)zookeeper_2_2_6_0_2800-3.4.6.2.2.6.0-2800.noarch(@System)
> 2015-08-25 00:52:53 <1> samsuse-1(23137) [zypp] SATResolver.cc(resolvePool):716
Delete I_Tu_(5682)zookeeper_2_2_6_0_2800-3.4.6.2.2.6.0-2800.noarch(@System)
> 2015-08-25 00:52:53 <1> samsuse-1(23137) [satsolver] PoolImpl.cc(logSat):101 job:
erase zookeeper_2_2_6_0_2800-3.4.6.2.2.6.0-2800.noarch
> 2015-08-25 00:52:53 <1> samsuse-1(23137) [satsolver] PoolImpl.cc(logSat):101  
  !zookeeper_2_2_6_0_2800-3.4.6.2.2.6.0-2800.noarch [387] (w1)
> 2015-08-25 00:52:53 <1> samsuse-1(23137) [satsolver] PoolImpl.cc(logSat):101  
  !zookeeper_2_2_6_0_2800-3.4.6.2.2.6.0-2800.noarch [5682]I (w1)
> 2015-08-25 00:52:53 <1> samsuse-1(23137) [zypper++] Summary.cc(readPool):133 <uninstall>
I_Tu_(5682)zookeeper_2_2_6_0_2800-3.4.6.2.2.6.0-2800.noarch(@System)
> 2015-08-25 00:52:58 <1> samsuse-1(23137) [zypp] RpmDb.cc(doRemovePackage):1899
RpmDb::doRemovePackage(zookeeper_2_2_6_0_2800-3.4.6.2.2.6.0-2800.noarch,0x00000008)
> 2015-08-25 00:52:58 <1> samsuse-1(23137) [zypp++] ExternalProgram.cc(start_program):229
Executing 'rpm' '--root' '/' '--dbpath' '/var/lib/rpm' '-e' '--allmatches' '--nodeps' '--'
'zookeeper_2_2_6_0_2800-3.4.6.2.2.6.0-2800.noarch'
>  



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message