ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Lysnichenko (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-12425) Manual Stack Upgrade - Unable to set current after upgrade from 2.2 -> 2.3
Date Wed, 15 Jul 2015 18:58:04 GMT
Dmitry Lysnichenko created AMBARI-12425:
-------------------------------------------

             Summary: Manual Stack Upgrade - Unable to set current after upgrade from 2.2
-> 2.3
                 Key: AMBARI-12425
                 URL: https://issues.apache.org/jira/browse/AMBARI-12425
             Project: Ambari
          Issue Type: Bug
          Components: ambari-server
            Reporter: Dmitry Lysnichenko
            Assignee: Dmitry Lysnichenko
             Fix For: 2.1.1


1) Ambari 2.0.0 + HDP 2.2.6, hdfs, yarn, mr, zk
2) upgrade to Ambari 2.1.0 build #1455
3) All looks good. Perform manual upgrade to HDP 2.3 #2557
4) All looks good. Go to finish and set-current. fails.

{code}
[root@c6401 conf]# ambari-server set-current --cluster-name=MyCluster --version-display-name=HDP-2.3.0.0
Using python  /usr/bin/python2.6
Setting current version...
Enter Ambari Admin login: admin
Enter Ambari Admin password: 
ERROR: Exiting with exit code 1. 
REASON: Error during setting current version. Http status code - 500. 
 {
  "status" : 500,
  "message" : "org.apache.ambari.server.controller.spi.SystemException: Finalization failed.
More details: \nSTDOUT: Begin finalizing the upgrade of cluster MyCluster to version 2.3.0.0-2557\n\nSTDERR:
Cluster stack version 2.3.0.0-2557 not found"
}
{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message