ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-12391) Rolling upgrade failed on Hive restart for Centos 7
Date Mon, 13 Jul 2015 11:45:04 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-12391?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14624555#comment-14624555
] 

Hudson commented on AMBARI-12391:
---------------------------------

SUCCESS: Integrated in Ambari-branch-2.1 #216 (See [https://builds.apache.org/job/Ambari-branch-2.1/216/])
AMBARI-12391. Rolling upgrade failed on Hive restart for Centos 7 (dlysnichenko) (dlysnichenko:
http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=e2b2eb3499793e0f4f5a27db93de8d7ae39c8e20)
* ambari-server/src/main/resources/common-services/HIVE/0.12.0.2.0/package/scripts/hive_metastore.py
* ambari-server/src/test/python/stacks/2.1/HIVE/test_hive_metastore.py


> Rolling upgrade failed on Hive restart for Centos 7
> ---------------------------------------------------
>
>                 Key: AMBARI-12391
>                 URL: https://issues.apache.org/jira/browse/AMBARI-12391
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Dmitry Lysnichenko
>            Assignee: Dmitry Lysnichenko
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-12391.2.patch, AMBARI-12391.patch
>
>
> It's a Metastore restart failure
> {code}
> 2015-07-09 18:10:15,641 - Executing Metastore Rolling Upgrade pre-restart
> 2015-07-09 18:10:15,643 - Upgrading Hive Metastore
> 2015-07-09 18:10:15,645 - Execute['('cp', '/usr/hdp/current/hive-metastore/lib/mysql-connector-java.jar',
u'/usr/hdp/2.3.0.0-2545/hive/lib')'] {'path': ['/bin', '/usr/bin/'], 'sudo': True}
> 2015-07-09 18:10:15,682 - Execute['/usr/hdp/2.3.0.0-2545/hive/bin/schematool -dbType
mysql -upgradeSchema'] {'logoutput': True, 'environment': {'HIVE_CONF_DIR': '/usr/hdp/current/hive-metastore/conf/conf.server'},
'tries': 1, 'user': 'hive'}
> WARNING: Use "yarn jar" to launch YARN applications.
> org.apache.hadoop.hive.metastore.HiveMetaException: Failed to load driver
> *** schemaTool failed ***
> {code}
> When I tried a dryrun,
> {code}
> sudo -u hive /usr/hdp/2.3.0.0-2545/hive/bin/schematool -dryRun -dbType mysql -upgradeSchema
> {code}
> it doesn't seem to fail on the driver load issue, though it was failing on something
else.
> I am assuming this is related to us missing some libraries during rolling-upgrades.
> But we need to find out what exactly it is that is missing. Is it mysql-connector-java.jar
? Does it need to be readable by hive user, given the ugpradeSchema command above is running
as hive?
> {code}
> # ls -l /usr/hdp/2.3.0.0-2545/hive/lib/mysql-connector-java.jar
> -rw-r-----. 1 root root 959987 Jul  9 18:10 /usr/hdp/2.3.0.0-2545/hive/lib/mysql-connector-java.jar
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message