ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMBARI-12232) upgradeHelper for a 2.1 -> 2.2 upgrade leaves Resource Manager unusable
Date Wed, 01 Jul 2015 09:19:04 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-12232?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Onischuk resolved AMBARI-12232.
--------------------------------------
    Resolution: Fixed

Committed to trunk and branch-2.1

> upgradeHelper for a 2.1 -> 2.2 upgrade leaves Resource Manager unusable
> -----------------------------------------------------------------------
>
>                 Key: AMBARI-12232
>                 URL: https://issues.apache.org/jira/browse/AMBARI-12232
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 2.1.0
>
>
> PROBLEM: The upgradeHelper script when upgrading from 2.1 -> 2.2 sets up YARN
> to use ZKRMStateStore. It also sets the zk-address to localhost:2181:
>     
>     
>     
>               "yarn.resourcemanager.store.class": "org.apache.hadoop.yarn.server.resourcemanager.recovery.ZKRMStateStore",
>               "yarn.resourcemanager.zk-address": "localhost:2181",
>     
> This leaves the RM unable to start because it has no quorum to connect to. The
> upgradeHelper should either not set the ZKRMStateStore, or it should be trying
> harder to populate a valid ZK quorum.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message