ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vijay Srinivasaraghavan <vijikar...@yahoo.com.INVALID>
Subject Ambari Build Failed
Date Fri, 10 Jul 2015 00:09:50 GMT
Hello,



I am trying to build Ambari from the trunk using the Docker option under ${AMBARI_HOME}/dev-support/docker/docker
I am getting below error when it is trying to build the ambari-web module. It looks like NPM
is broken.
Since it is a docker based build, I assume it should not be relatd to any environment releated
issue since the build is happening from with the CentOS6 container.
Did anyone see this issue?
> contextify@0.1.14 install /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/contextify>
node-gyp rebuild
npm http 304 https://registry.npmjs.org/delayed-streamnpm http 304 https://registry.npmjs.org/mime-dbnpm
http GET https://registry.npmjs.org/formidablenpm http 304 https://registry.npmjs.org/formidablenpm
http GET https://registry.npmjs.org/entitiesnpm http GET https://registry.npmjs.org/domhandlernpm
http GET https://registry.npmjs.org/domutilsnpm http GET https://registry.npmjs.org/domelementtypenpm
http 304 https://registry.npmjs.org/entitiesnpm http 304 https://registry.npmjs.org/domhandlernpm
make: Entering directory `/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/contextify/build'make:
Warning: File `../../../../../../../../../../usr/share/node/common.gypi' has modification
time 6.1e+05 s in the futurehttp 304 https://registry.npmjs.org/domutils  ACTION Regenerating
Makefilenpm http 304 https://registry.npmjs.org/domelementtypeTraceback (most recent call
last):  File "/usr/bin/gyp", line 18, in <module>    sys.exit(gyp.main(sys.argv[1:])) 
File "/usr/lib/python2.6/site-packages/gyp/__init__.py", line 462, in main    options.circular_check) 
File "/usr/lib/python2.6/site-packages/gyp/__init__.py", line 100, in Load    depth, generator_input_info,
check, circular_check)  File "/usr/lib/python2.6/site-packages/gyp/input.py", line 2255,
in Load    depth, check)  File "/usr/lib/python2.6/site-packages/gyp/input.py", line 362,
in LoadTargetBuildFile    includes, True, check)  File "/usr/lib/python2.6/site-packages/gyp/input.py",
line 209, in LoadOneBuildFile    raise Exception("%s not found (cwd: %s)" % (build_file_path,
os.getcwd()))Exception: binding.gyp not found (cwd: /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/contextify/build)
while trying to load binding.gypmake: *** [Makefile] Error 1make: Leaving directory `/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/contextify/build'gyp
ERR! build errorgyp ERR! stack Error: `make` failed with exit code: 2gyp ERR! stack    
at ChildProcess.onExit (/usr/lib/node_modules/node-gyp/lib/build.js:267:23)gyp ERR! stack
    at ChildProcess.emit (events.js:98:17)gyp ERR! stack     at Process.ChildProcess._handle.onexit
(child_process.js:820:12)gyp ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultgyp ERR! command
"node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"gyp ERR!
cwd /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/contextifygyp
ERR! node -v v0.10.36gyp ERR! node-gyp -v v0.10.6gyp ERR! not oknpm http GET https://registry.npmjs.org/bluebirdnpm
http GET https://registry.npmjs.org/chalknpm http GET https://registry.npmjs.org/is-my-json-validnpm
ERR! Error: ENOENT, lstat '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/entities/LICENSE'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/entities/LICENSEnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/entities/LICENSEnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code ENOENTnpm ERR! errno
34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:284:26npm ERR! fstream_stack
Object.oncomplete (fs.js:108:15)npm ERR! Error: ENOENT, utime '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/domhandler/LICENSE'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/domhandler/LICENSEnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/domhandler/LICENSEnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! fstream_finish_call utimesnpm
ERR! code ENOENTnpm ERR! errno 34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:305:19npm
ERR! fstream_stack Object.oncomplete (fs.js:108:15)npm ERR! error rolling back Error: ENOTEMPTY,
rmdir '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/domelementtype'npm
ERR! error rolling back  jsdom@0.6.5 { [Error: ENOTEMPTY, rmdir '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/domelementtype']npm
ERR! error rolling back   errno: 53,npm ERR! error rolling back   code: 'ENOTEMPTY',npm
ERR! error rolling back   path: '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/domelementtype'
}npm ERR! EEXIST, mkdir '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/readable-stream'File
exists: /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/readable-streamMove
it away, and try again.
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/readable-streamnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/readable-stream/README.mdnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code EEXISTnpm ERR! errno
47npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:171:23npm ERR! fstream_stack
/usr/lib/node_modules/mkdirp/index.js:37:53npm ERR! fstream_stack Object.oncomplete (fs.js:108:15)npm
ERR! EEXIST, mkdir '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/domutils'File
exists: /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/domutilsMove
it away, and try again.
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/domutilsnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/htmlparser2/node_modules/domutils/LICENSEnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code EEXISTnpm ERR! errno
47npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:171:23npm ERR! fstream_stack
/usr/lib/node_modules/mkdirp/index.js:37:53npm ERR! fstream_stack Object.oncomplete (fs.js:108:15)npm
http 304 https://registry.npmjs.org/bluebirdnpm http 304 https://registry.npmjs.org/is-my-json-validnpm
http 304 https://registry.npmjs.org/chalknpm ERR! EEXIST, mkdir '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/http-signature/node_modules/ctype'File
exists: /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/http-signature/node_modules/ctypeMove
it away, and try again.
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/http-signature/node_modules/ctypenpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/http-signature/node_modules/ctype/ctype.jsnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code EEXISTnpm ERR! errno
47npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:171:23npm ERR! fstream_stack
/usr/lib/node_modules/mkdirp/index.js:37:53npm ERR! fstream_stack Object.oncomplete (fs.js:108:15)npm
ERR! Error: ENOENT, lstat '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/qs/test/stringify.js'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/qs/test/stringify.jsnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/qs/test/stringify.jsnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code ENOENTnpm ERR! errno
34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:284:26npm ERR! fstream_stack
Object.oncomplete (fs.js:108:15)npm ERR! Error: ENOENT, lstat '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/form-data/node_modules/mime-types/node_modules/mime-db/README.md'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/form-data/node_modules/mime-types/node_modules/mime-db/README.mdnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/form-data/node_modules/mime-types/node_modules/mime-db/README.mdnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code ENOENTnpm ERR! errno
34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:284:26npm ERR! fstream_stack
Object.oncomplete (fs.js:108:15)npm ERR! Error: ENOENT, lstat '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/form-data/node_modules/async/README.md'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/form-data/node_modules/async/README.mdnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/form-data/node_modules/async/README.mdnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code ENOENTnpm ERR! errno
34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:284:26npm ERR! fstream_stack
Object.oncomplete (fs.js:108:15)npm ERR! EEXIST, mkdir '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/bl/node_modules/readable-stream/lib'File
exists: /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/bl/node_modules/readable-stream/libMove
it away, and try again.
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/bl/node_modules/readable-stream/libnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/bl/node_modules/readable-stream/lib/_stream_passthrough.jsnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code EEXISTnpm ERR! errno
47npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:171:23npm ERR! fstream_stack
/usr/lib/node_modules/mkdirp/index.js:37:53npm ERR! fstream_stack Object.oncomplete (fs.js:108:15)npm
ERR! Error: ENOENT, lstat '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/http-signature/node_modules/asn1/lib/ber/reader.js'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/http-signature/node_modules/asn1/lib/ber/reader.jsnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/http-signature/node_modules/asn1/lib/ber/reader.jsnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code ENOENTnpm ERR! errno
34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:284:26npm ERR! fstream_stack
Object.oncomplete (fs.js:108:15)npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules'npm
ERR! error rolling back  karma-ember-precompiler-brunch@0.0.2 { [Error: ENOTEMPTY, rmdir
'/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules']npm
ERR! error rolling back   errno: 53,npm ERR! error rolling back   code: 'ENOTEMPTY',npm
ERR! error rolling back   path: '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules'
}npm ERR! weird error 1npm http GET https://registry.npmjs.org/argparsenpm ERR! Error: ENOENT,
lstat '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/hawk/images/logo.png'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/hawk/images/logo.pngnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/hawk/images/logo.pngnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code ENOENTnpm ERR! errno
34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:284:26npm ERR! fstream_stack
Object.oncomplete (fs.js:108:15)npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/har-validator/node_modules'npm
ERR! error rolling back  request@2.58.0 { [Error: ENOTEMPTY, rmdir '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/har-validator/node_modules']npm
ERR! error rolling back   errno: 53,npm ERR! error rolling back   code: 'ENOTEMPTY',npm
ERR! error rolling back   path: '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/har-validator/node_modules'
}npm ERR! Error: ENOENT, lstat '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/har-validator/node_modules/chalk/index.js'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/har-validator/node_modules/chalk/index.jsnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/har-validator/node_modules/chalk/index.jsnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code ENOENTnpm ERR! errno
34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:284:26npm ERR! fstream_stack
Object.oncomplete (fs.js:108:15)npm http 304 https://registry.npmjs.org/argparsenpm ERR! Error:
ENOENT, lstat '/root/tmp/npm-1984-ix4_mXSK/1421691198290-0.7568058390170336/package/.bob/complexity/plato/assets/font/fontawesome-webfont.ttf'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /root/tmp/npm-1984-ix4_mXSK/1421691198290-0.7568058390170336/package/.bob/complexity/plato/assets/font/fontawesome-webfont.ttfnpm
ERR! fstream_path /root/tmp/npm-1984-ix4_mXSK/1421691198290-0.7568058390170336/package/.bob/complexity/plato/assets/font/fontawesome-webfont.ttfnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code ENOENTnpm ERR! errno
34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:284:26npm ERR! fstream_stack
Object.oncomplete (fs.js:108:15)npm ERR! Error: ENOENT, lstat '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/har-validator/node_modules/commander/index.js'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/har-validator/node_modules/commander/index.jsnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/har-validator/node_modules/commander/index.jsnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code ENOENTnpm ERR! errno
34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:284:26npm ERR! fstream_stack
Object.oncomplete (fs.js:108:15)npm ERR! Error: ENOENT, lstat '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/har-validator/node_modules/bluebird/README.md'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/har-validator/node_modules/bluebird/README.mdnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/har-validator/node_modules/bluebird/README.mdnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code ENOENTnpm ERR! errno
34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:284:26npm ERR! fstream_stack
Object.oncomplete (fs.js:108:15)npm ERR! Error: ENOENT, lstat '/tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/mime-types/node_modules/mime-db/db.json'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/mime-types/node_modules/mime-db/db.jsonnpm
ERR! fstream_path /tmp/ambari/ambari-web/node_modules/karma-ember-precompiler-brunch/node_modules/jsdom/node_modules/request/node_modules/mime-types/node_modules/mime-db/db.jsonnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code ENOENTnpm ERR! errno
34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:284:26npm ERR! fstream_stack
Object.oncomplete (fs.js:108:15)
> phantomjs@1.9.17 install /tmp/ambari/ambari-web/node_modules/phantomjs> node install.js

> contextify@0.1.14 install /tmp/ambari/ambari-web/node_modules/ember-precompiler-brunch/node_modules/jsdom/node_modules/contextify>
node-gyp rebuild
npm http GET https://registry.npmjs.org/amdefinenpm http 304 https://registry.npmjs.org/amdefine
> clean-css-brunch@1.4.0 postinstall /tmp/ambari/ambari-web/node_modules/clean-css-brunch>
node setup.js postinstall
Downloading https://bitbucket.org/ariya/phantomjs/downloads/phantomjs-1.9.8-linux-x86_64.tar.bz2Saving
to /tmp/ambari/ambari-web/node_modules/phantomjs/phantomjs/phantomjs-1.9.8-linux-x86_64.tar.bz2Receiving...make:
Entering directory `/tmp/ambari/ambari-web/node_modules/ember-precompiler-brunch/node_modules/jsdom/node_modules/contextify/build'make:
Warning: File `../../../../../../../../../../usr/share/node/common.gypi' has modification
time 6.1e+05 s in the future  ACTION Regenerating Makefile
Error making request.Error: CERT_NOT_YET_VALID    at SecurePair.<anonymous> (tls.js:1381:32) 
  at SecurePair.emit (events.js:92:17)    at SecurePair.maybeInitFinished (tls.js:980:10) 
  at CleartextStream.read [as _read] (tls.js:472:13)    at CleartextStream.Readable.read
(_stream_readable.js:341:10)    at EncryptedStream.write [as _write] (tls.js:369:25)   
at doWrite (_stream_writable.js:226:10)    at writeOrBuffer (_stream_writable.js:216:5) 
  at EncryptedStream.Writable.write (_stream_writable.js:183:11)    at write (_stream_readable.js:602:24)
Please report this full log at https://github.com/Medium/phantomjsTraceback (most recent call
last):  File "/usr/bin/gyp", line 18, in <module>    sys.exit(gyp.main(sys.argv[1:])) 
File "/usr/lib/python2.6/site-packages/gyp/__init__.py", line 462, in main    options.circular_check) 
File "/usr/lib/python2.6/site-packages/gyp/__init__.py", line 100, in Load    depth, generator_input_info,
check, circular_check)  File "/usr/lib/python2.6/site-packages/gyp/input.py", line 2255,
in Load    depth, check)  File "/usr/lib/python2.6/site-packages/gyp/input.py", line 362,
in LoadTargetBuildFile    includes, True, check)  File "/usr/lib/python2.6/site-packages/gyp/input.py",
line 209, in LoadOneBuildFile    raise Exception("%s not found (cwd: %s)" % (build_file_path,
os.getcwd()))Exception: binding.gyp not found (cwd: /tmp/ambari/ambari-web/node_modules/ember-precompiler-brunch/node_modules/jsdom/node_modules/contextify/build)
while trying to load binding.gypmake: *** [Makefile] Error 1make: Leaving directory `/tmp/ambari/ambari-web/node_modules/ember-precompiler-brunch/node_modules/jsdom/node_modules/contextify/build'gyp
ERR! build errorgyp ERR! stack Error: `make` failed with exit code: 2gyp ERR! stack    
at ChildProcess.onExit (/usr/lib/node_modules/node-gyp/lib/build.js:267:23)gyp ERR! stack
    at ChildProcess.emit (events.js:98:17)gyp ERR! stack     at Process.ChildProcess._handle.onexit
(child_process.js:820:12)gyp ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultgyp ERR! command
"node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"gyp ERR!
cwd /tmp/ambari/ambari-web/node_modules/ember-precompiler-brunch/node_modules/jsdom/node_modules/contextifygyp
ERR! node -v v0.10.36gyp ERR! node-gyp -v v0.10.6gyp ERR! not oknpm WARN optional dep failed,
continuing contextify@0.1.14npm http GET https://registry.npmjs.org/commandernpm http 304
https://registry.npmjs.org/commandernpm http GET https://registry.npmjs.org/mkdirp/0.3.0npm
http GET https://registry.npmjs.org/ycssminnpm http GET https://registry.npmjs.org/lodashnpm
http GET https://registry.npmjs.org/sprintf-jsnpm http 304 https://registry.npmjs.org/mkdirp/0.3.0npm
http 304 https://registry.npmjs.org/ycssminnpm http 304 https://registry.npmjs.org/lodashnpm
http 304 https://registry.npmjs.org/sprintf-jsnpm http GET https://registry.npmjs.org/generate-functionnpm
http GET https://registry.npmjs.org/generate-object-propertynpm http GET https://registry.npmjs.org/jsonpointernpm
http GET https://registry.npmjs.org/xtendnpm http 304 https://registry.npmjs.org/generate-object-propertynpm
http 304 https://registry.npmjs.org/jsonpointernpm http 304 https://registry.npmjs.org/xtendnpm
http 304 https://registry.npmjs.org/generate-function
> javascript-brunch@1.3.0 postinstall /tmp/ambari/ambari-web/node_modules/javascript-brunch>
node setup.js postinstall
npm http GET https://registry.npmjs.org/is-propertynpm http GET https://registry.npmjs.org/optimistnpm
http GET https://registry.npmjs.org/uglify-jsnpm http 304 https://registry.npmjs.org/is-propertynpm
http 304 https://registry.npmjs.org/optimistnpm http 304 https://registry.npmjs.org/uglify-jsnpm
http GET https://registry.npmjs.org/buster-formatnpm http 304 https://registry.npmjs.org/buster-formatnpm
http GET https://registry.npmjs.org/buster-core/0.6.4npm http GET https://registry.npmjs.org/minimistnpm
http 304 https://registry.npmjs.org/buster-core/0.6.4npm http 304 https://registry.npmjs.org/minimist
> less-brunch@1.4.1 postinstall /tmp/ambari/ambari-web/node_modules/less-brunch> node
setup.js postinstall

> uglify-js-brunch@1.3.1 postinstall /tmp/ambari/ambari-web/node_modules/uglify-js-brunch>
node setup.js postinstall
npm ERR! Error: ENOENT, lstat '/root/tmp/npm-1984-ix4_mXSK/1421691198290-0.7124210870824754/package/test/fixtures/pgts.yaml'npm
ERR! If you need help, you may report this log at:npm ERR!     <http://github.com/isaacs/npm/issues>npm
ERR! or email it to:npm ERR!     <npm-@googlegroups.com>
npm ERR! System Linux 3.12.36-38.1.8020.1.PTF-defaultnpm ERR! command "node" "/usr/bin/npm"
"install"npm ERR! cwd /tmp/ambari/ambari-webnpm ERR! node -v v0.10.36npm ERR! npm -v 1.3.6npm
ERR! path /root/tmp/npm-1984-ix4_mXSK/1421691198290-0.7124210870824754/package/test/fixtures/pgts.yamlnpm
ERR! fstream_path /root/tmp/npm-1984-ix4_mXSK/1421691198290-0.7124210870824754/package/test/fixtures/pgts.yamlnpm
ERR! fstream_type Filenpm ERR! fstream_class FileWriternpm ERR! code ENOENTnpm ERR! errno
34npm ERR! fstream_stack /usr/lib/node_modules/fstream/lib/writer.js:284:26npm ERR! fstream_stack
Object.oncomplete (fs.js:108:15)npm http GET https://registry.npmjs.org/hoeknpm http GET https://registry.npmjs.org/boomnpm
http GET https://registry.npmjs.org/cryptilesnpm http GET https://registry.npmjs.org/sntpnpm
http 304 https://registry.npmjs.org/boomnpm http 304 https://registry.npmjs.org/sntpnpm http
304 https://registry.npmjs.org/cryptilesnpm http 304 https://registry.npmjs.org/hoeknpm http
GET https://registry.npmjs.org/core-util-isnpm http GET https://registry.npmjs.org/isarray/0.0.1npm
http GET https://registry.npmjs.org/string_decodernpm http GET https://registry.npmjs.org/inheritsnpm
http 304 https://registry.npmjs.org/string_decodernpm http 304 https://registry.npmjs.org/core-util-isnpm
http 304 https://registry.npmjs.org/inheritsnpm http 304 https://registry.npmjs.org/isarray/0.0.1npm
http GET https://registry.npmjs.org/ansi-stylesnpm http GET https://registry.npmjs.org/escape-string-regexpnpm
http GET https://registry.npmjs.org/has-ansinpm http GET https://registry.npmjs.org/strip-ansinpm
http GET https://registry.npmjs.org/supports-colornpm http GET https://registry.npmjs.org/graceful-readlinknpm
http 304 https://registry.npmjs.org/escape-string-regexpnpm http 304 https://registry.npmjs.org/supports-colornpm
http 304 https://registry.npmjs.org/strip-ansinpm http 304 https://registry.npmjs.org/ansi-stylesnpm
http 304 https://registry.npmjs.org/has-ansinpm http 304 https://registry.npmjs.org/graceful-readlinknpm
http GET https://registry.npmjs.org/ansi-regexnpm http 304 https://registry.npmjs.org/ansi-regex
> ember-precompiler-brunch@1.4.1 postinstall /tmp/ambari/ambari-web/node_modules/ember-precompiler-brunch>
node setup.js postinstall
npm ERR!npm ERR! Additional logging details can be found in:npm ERR!     /tmp/ambari/ambari-web/npm-debug.lognpm
ERR! not ok code 0[INFO] ------------------------------------------------------------------------[INFO]
Reactor Summary:[INFO][INFO] Ambari Web ........................................ FAILURE [1:12.584s][INFO]
Ambari Views ...................................... SKIPPED[INFO] Ambari Admin View .................................
SKIPPED[INFO] ambari-metrics .................................... SKIPPED[INFO] Ambari Metrics
Common ............................. SKIPPED[INFO] Ambari Metrics Hadoop Sink ........................
SKIPPED[INFO] Ambari Metrics Flume Sink ......................... SKIPPED[INFO] Ambari Metrics
Kafka Sink ......................... SKIPPED[INFO] Ambari Metrics Storm Sink .........................
SKIPPED[INFO] Ambari Metrics Collector .......................... SKIPPED[INFO] Ambari Metrics
Monitor ............................ SKIPPED[INFO] Ambari Metrics Assembly ...........................
SKIPPED[INFO] Ambari Server ..................................... SKIPPED[INFO] Ambari Agent
...................................... SKIPPED[INFO] Ambari Client .....................................
SKIPPED[INFO] Ambari Python Client .............................. SKIPPED[INFO] Ambari Groovy
Client .............................. SKIPPED[INFO] Ambari Shell ......................................
SKIPPED[INFO] Ambari Python Shell ............................... SKIPPED[INFO] Ambari Groovy
Shell ............................... SKIPPED[INFO] ------------------------------------------------------------------------[INFO]
BUILD FAILURE[INFO] ------------------------------------------------------------------------[INFO]
Total time: 1:17.114s[INFO] Finished at: Mon Jan 19 18:14:24 GMT 2015[INFO] Final Memory:
12M/59M[INFO] ------------------------------------------------------------------------[ERROR]
Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.2.1:exec (compile-npm) on project
ambari-web: Command execution failed. Process exited with an error: 34 (Exit value: 34) ->
[Help 1]org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.2.1:exec
(compile-npm) on project ambari-web: Command execution failed.        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:217) 
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153) 
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145) 
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84) 
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59) 
      at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183) 
      at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161) 
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156) 
      at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)        at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196) 
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) 
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) 
      at java.lang.reflect.Method.invoke(Method.java:597)        at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290) 
      at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230) 
      at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409) 
      at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)Caused
by: org.apache.maven.plugin.MojoExecutionException: Command execution failed.        at
org.codehaus.mojo.exec.ExecMojo.execute(ExecMojo.java:362)        at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101) 
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209) 
      ... 19 moreCaused by: org.apache.commons.exec.ExecuteException: Process exited with
an error: 34 (Exit value: 34)        at org.apache.commons.exec.DefaultExecutor.executeInternal(DefaultExecutor.java:377) 
      at org.apache.commons.exec.DefaultExecutor.execute(DefaultExecutor.java:160)   
    at org.codehaus.mojo.exec.ExecMojo.executeCommandLine(ExecMojo.java:610)       
at org.codehaus.mojo.exec.ExecMojo.execute(ExecMojo.java:352)        ... 21 more[ERROR][ERROR][ERROR]
For more information about the errors and possible solutions, please read the following articles:[ERROR]
[Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException


RegardsVijay

   
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message