ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "李思宇" <siyu...@criwell.com>
Subject Building from source brunch not found
Date Wed, 22 Jul 2015 12:11:31 GMT

Hi

I am trying to build ambari from source.
 I am always getting error due to brunch not installed.

 I have version 1.8.3 installed on Mac

 I am following instructions on wiki of Ambari. 
https://cwiki.apache.org/confluence/display/AMBARI/Quick+Start+GuideFrontend Developmentcd
ambari-vagrant/centos6.4git clone https://git-wip-us.apache.org/repos/asf/ambari.git ambaricd
ambari/ambari-webnpm installbrunch w

D:\ambari\ambari-vagrant\centos6.4\ambari\ambari-web>brunch w
C:\Users\xyuser\AppData\Roaming\npm\node_modules\brunch\lib\watch.js:446
          throw new Error("You probably need to execute `npm install` to insta
                ^
Error: You probably need to execute `npm install` to install brunch plugins. Syn
taxError: D:\ambari\ambari-vagrant\centos6.4\ambari\ambari-web\node_modules\embe
r-precompiler-brunch\node_modules\jsdom\lib\jsdom\level1\core.js:418
  set nodeName() { throw new core.DOMException();},
               ^
Unexpected token )
  at C:\Users\xyuser\AppData\Roaming\npm\node_modules\brunch\lib\watch.js:446:17

  at Array.map (native)
  at loadDeps (C:\Users\xyuser\AppData\Roaming\npm\node_modules\brunch\lib\watch
.js:431:8)
  at loadPackages (C:\Users\xyuser\AppData\Roaming\npm\node_modules\brunch\lib\w
atch.js:451:13)
  at C:\Users\xyuser\AppData\Roaming\npm\node_modules\brunch\lib\watch.js:471:17

  at C:\Users\xyuser\AppData\Roaming\npm\node_modules\brunch\lib\helpers.js:597:
12
  at C:\Users\xyuser\AppData\Roaming\npm\node_modules\brunch\lib\helpers.js:558:
16
  at C:\Users\xyuser\AppData\Roaming\npm\node_modules\brunch\lib\helpers.js:507:
12
  at C:\Users\xyuser\AppData\Roaming\npm\node_modules\brunch\node_modules\read-c
omponents\index.js:263:16
  at C:\Users\xyuser\AppData\Roaming\npm\node_modules\brunch\node_modules\read-c
omponents\index.js:72:14
  at FSReqWrap.cb [as oncomplete] (fs.js:226:19)


D:\ambari\ambari-vagrant\centos6.4\ambari\ambari-web>
D:\ambari\ambari-vagrant\centos6.4\ambari\ambari-web>
D:\ambari\ambari-vagrant\centos6.4\ambari\ambari-web>npm install
npm WARN package.json Ambari@2.1.0 No README data
npm WARN package.json Ambari@2.1.0 No license field.

D:\ambari\ambari-vagrant\centos6.4\ambari\ambari-web>brunch version
1.8.3



 How to fix this.

Thanks in advance


siyu li
  

 
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message