ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-12169) Ambari RU doesn't work with Redhat satellite
Date Fri, 26 Jun 2015 21:15:05 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-12169?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14603594#comment-14603594
] 

Hudson commented on AMBARI-12169:
---------------------------------

FAILURE: Integrated in Ambari-branch-2.1 #123 (See [https://builds.apache.org/job/Ambari-branch-2.1/123/])
AMBARI-12169 Ambari RU doesn't work with Redhat satellite (dsen) (dsen: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=ec1705aecb66863caab54e01130b69037811a2cb)
* ambari-common/src/main/python/resource_management/core/providers/package/apt.py
* ambari-common/src/main/python/resource_management/core/resources/packaging.py
* ambari-common/src/main/python/resource_management/core/providers/package/zypper.py
* ambari-common/src/main/python/resource_management/core/providers/package/__init__.py
* ambari-common/src/main/python/resource_management/core/providers/package/yumrpm.py
* ambari-common/src/main/python/resource_management/core/providers/package/choco.py
* ambari-server/src/main/resources/custom_actions/scripts/install_packages.py
* ambari-server/src/test/python/custom_actions/TestInstallPackages.py


> Ambari RU doesn't work with Redhat satellite
> --------------------------------------------
>
>                 Key: AMBARI-12169
>                 URL: https://issues.apache.org/jira/browse/AMBARI-12169
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-agent
>    Affects Versions: 2.0.0, 2.0.1
>            Reporter: Dmytro Sen
>            Assignee: Dmytro Sen
>            Priority: Critical
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-12169.patch
>
>
> PROBLEM: If the regular repository is not used, set up RH satellite and subscribed to
some particular channel for yum install, there is not repo file under /etc/yum.repos.d/, and
nothing can be put into the repository url in Ambari. This can be workaround, but when ambari
doing the RU, the command is: 
> {code}
> /usr/bin/yum -d 0 -e 0 -y install '--disablerepo=*' --enablerepo=base,HDP-UTILS-2.2.4.2,HDP-2.2.4.2
'hadoop_2_2_*'
> {code}
> This will disable all the repository channels in the RH satellite. So the install will
fail. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message