ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Halterman (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-12134) Update poms to target 1.7 and 1.6 JREs
Date Wed, 24 Jun 2015 20:20:04 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-12134?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Halterman updated AMBARI-12134:
----------------------------------------
    Description: The ambari parent pom is targeted towards Java 1.6 while ambari uses 1.7
APIs. The ambari metrics pom is targeted at java 1.5 (by default) while ambari-metrics uses
1.6 APIs. This causes basic compilation failures, depending on how you build the projects
and what tools you use to work on them. The targeted Java versions in the POMs should be updated.
 (was: The ambari parent pom is targeted towards Java 1.6 while ambari uses 1.7 APIs. The
ambari metrics pom is targeted at java 1.5 (by default) while ambari-metrics uses 1.6 APIs.
The Java versions in the POMs should be updated.)

> Update poms to target 1.7 and 1.6 JREs
> --------------------------------------
>
>                 Key: AMBARI-12134
>                 URL: https://issues.apache.org/jira/browse/AMBARI-12134
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: ambari-2.1.0
>            Reporter: Jonathan Halterman
>            Assignee: Jonathan Halterman
>         Attachments: AMBARI-12134.patch
>
>
> The ambari parent pom is targeted towards Java 1.6 while ambari uses 1.7 APIs. The ambari
metrics pom is targeted at java 1.5 (by default) while ambari-metrics uses 1.6 APIs. This
causes basic compilation failures, depending on how you build the projects and what tools
you use to work on them. The targeted Java versions in the POMs should be updated.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message