ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yusaku Sako (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-12134) Update poms to target 1.7 and 1.6 JREs
Date Thu, 25 Jun 2015 04:19:04 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-12134?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14600663#comment-14600663
] 

Yusaku Sako commented on AMBARI-12134:
--------------------------------------

[~jhalterman] good question.  You might want to do "git blame" and see who has been committing
changes in the areas of interest.

> Update poms to target 1.7 and 1.6 JREs
> --------------------------------------
>
>                 Key: AMBARI-12134
>                 URL: https://issues.apache.org/jira/browse/AMBARI-12134
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 2.1.0
>            Reporter: Jonathan Halterman
>            Assignee: Jonathan Halterman
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-12134.patch
>
>
> The ambari parent pom is targeted towards Java 1.6 while ambari uses 1.7 APIs. The ambari
metrics pom is targeted at java 1.5 (by default) while ambari-metrics uses 1.6 APIs. This
causes basic compilation failures, depending on how you build the projects and what tools
you use to work on them. AFAIK Ambari 2.1 and beyond are targeted at 1.7, so the Java versions
in the POMs should be updated to reflect this.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message