ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Di Li (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-12107) Moving RM on a RM HA enabled cluster does not update the yarn.resourcemanager.webapp.address and yarn.resourcemanager.webapp.https.address
Date Tue, 23 Jun 2015 20:42:43 GMT
Di Li created AMBARI-12107:
------------------------------

             Summary: Moving RM on a RM HA enabled cluster does not update the yarn.resourcemanager.webapp.address
and yarn.resourcemanager.webapp.https.address
                 Key: AMBARI-12107
                 URL: https://issues.apache.org/jira/browse/AMBARI-12107
             Project: Ambari
          Issue Type: Bug
          Components: ambari-web
    Affects Versions: 2.1.0.
            Reporter: Di Li
             Fix For: 2.1.0.


I have a 3 node cluster, node1, node2, and node3. 

1. I enabled RM HA, where the node1 and node 2 are the RM active and standby nodes respectively.
2. I then moved RM from node 1 to node 3 via the "Move ResourceManager" menu item on the UI.
The move finished successfully. 
3. I noticed yarn.resourcemanager.hostname.rm1 was changed from node1 to node3 correctly.
 yarn.resourcemanager.webapp.address.rm1 however still had value "node1:8088",  yarn.resourcemanager.webapp.https.address.rm1
still had value "node1:8090"

It seems to me that ambari-web\app\controllers\main\service\reassign\step4_controller.js only
updates yarn.resourcemanager.hostname.rm1(2) when moving the RM. It should also update the
web app http and https values. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message