ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-12094) Nimbus Upgrade Fails Due To Missing kinit Key When Kerberos Is Enabled
Date Tue, 23 Jun 2015 23:10:43 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-12094?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14598547#comment-14598547
] 

Hudson commented on AMBARI-12094:
---------------------------------

SUCCESS: Integrated in Ambari-branch-2.1 #98 (See [https://builds.apache.org/job/Ambari-branch-2.1/98/])
AMBARI-12094 - Nimbus Upgrade Fails Due To Missing kinit Key When Kerberos Is Enabled (jonathanhurley)
(jhurley: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=1b7bcf583a915cf867d18f2a95310ce0e1b5c100)
* ambari-server/src/test/python/stacks/2.3/STORM/test_storm_upgrade.py
* ambari-server/src/main/resources/common-services/STORM/0.9.1.2.1/package/scripts/storm_upgrade.py
* ambari-server/src/main/resources/common-services/STORM/0.9.1.2.1/package/scripts/params_linux.py
* ambari-server/src/test/python/stacks/2.3/configs/storm_default_secure.json


> Nimbus Upgrade Fails Due To Missing kinit Key When Kerberos Is Enabled
> ----------------------------------------------------------------------
>
>                 Key: AMBARI-12094
>                 URL: https://issues.apache.org/jira/browse/AMBARI-12094
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: ambari-2.1.0
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Blocker
>             Fix For: ambari-2.1.0
>
>         Attachments: AMBARI-12094.patch
>
>
> When upgrading STORM from HDP 2.2 to HDP 2.3 on a secure cluster, the upgrade fails while
attempting to remove storm data:
> {code}
> Code: 1, Out: 2015-06-23 09:52:24,883 - Clearing Storm data from ZooKeeper
> Traceback (most recent call last):
>   File "/var/lib/ambari-agent/cache/common-services/STORM/0.9.1.2.1/package/scripts/storm_upgrade.py",
line 165, in <module>
>     StormUpgrade().execute()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 216, in execute
>     method(env)
>   File "/var/lib/ambari-agent/cache/common-services/STORM/0.9.1.2.1/package/scripts/storm_upgrade.py",
line 66, in delete_storm_zookeeper_data
>     kinit_command=format("{kinit_path_local} -kt {smoke_user_keytab} {smokeuser_principal};
")
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/format.py",
line 89, in format
>     return ConfigurationFormatter().format(format_string, args, **result)
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/format.py",
line 53, in format
>     result_protected = self.vformat(format_string, args, all_params)
>   File "/usr/lib64/python2.6/string.py", line 549, in vformat
>     result = self._vformat(format_string, args, kwargs, used_args, 2)
>   File "/usr/lib64/python2.6/string.py", line 571, in _vformat
>     obj, arg_used = self.get_field(field_name, args, kwargs)
>   File "/usr/lib64/python2.6/string.py", line 632, in get_field
>     obj = self.get_value(first, args, kwargs)
>   File "/usr/lib64/python2.6/string.py", line 591, in get_value
>     return kwargs[key]
>   File "/usr/lib/python2.6/site-packages/resource_management/core/utils.py", line 50,
in __getitem__
>     return self._convert_value(self._dict[name])
> KeyError: 'kinit_path_local'
> {code}
> Looks like this is a secure cluster but {{kinit_path_local}} is not defined. This is
because STORM uses JAAS internally and should not need to kinit externally. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message