ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-12021) Upgrade scripts from 2.0.x to 2.1.0 should handle moving of 'ranger-hive-plugin-enabled' into 'hive_security_authorization'
Date Sat, 20 Jun 2015 03:07:08 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-12021?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14594332#comment-14594332
] 

Hudson commented on AMBARI-12021:
---------------------------------

FAILURE: Integrated in Ambari-trunk-Commit #2952 (See [https://builds.apache.org/job/Ambari-trunk-Commit/2952/])
AMBARI-12021 Upgrade scripts from 2.0.x to 2.1.0 should handle moving of 'ranger-hive-plugin-enabled'
into 'hive_security_authorization' (dsen) (dsen: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=61fc03f174220c2dfb4a996196b6c80f31e2cd10)
* ambari-server/src/main/java/org/apache/ambari/server/upgrade/AbstractUpgradeCatalog.java
* ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog210Test.java
* ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog210.java


> Upgrade scripts from 2.0.x to 2.1.0 should handle moving of 'ranger-hive-plugin-enabled'
into 'hive_security_authorization'
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-12021
>                 URL: https://issues.apache.org/jira/browse/AMBARI-12021
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 2.1.0
>            Reporter: Dmytro Sen
>            Assignee: Dmytro Sen
>            Priority: Critical
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-12021.patch
>
>
> * We will remove the "Enable Ranger for Hive" (ranger-hive-plugin-enabled) checkbox from
Hive
> * The 'Ranger' entry in "Choose Authorization" (hive_security_authorization) will do
the same things as the removed checkbox
> Upgrade script should take care of setting the new config, and any of its dependencies.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message