ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jayush Luniya (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-11990) Deployment fails on snappy with HDP 2.3 on CentOS7
Date Fri, 19 Jun 2015 23:32:01 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-11990?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14594101#comment-14594101
] 

Jayush Luniya commented on AMBARI-11990:
----------------------------------------

Trunk:
commit d825760843d29fe818811d1ee4c647dd64c418b3
Author: Jayush Luniya <jluniya@hortonworks.com>
Date:   Fri Jun 19 16:29:52 2015 -0700

    AMBARI-11990: Deployment fails on snappy with HDP 2.3 on CentOS7 (jluniya)

Branch-2.1:
commit 63f4ed0adb2ba9452f2e9071e54eed8588376b4d
Author: Jayush Luniya <jluniya@hortonworks.com>
Date:   Fri Jun 19 16:29:52 2015 -0700

    AMBARI-11990: Deployment fails on snappy with HDP 2.3 on CentOS7 (jluniya)

> Deployment fails on snappy with HDP 2.3 on CentOS7
> --------------------------------------------------
>
>                 Key: AMBARI-11990
>                 URL: https://issues.apache.org/jira/browse/AMBARI-11990
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.1.0
>            Reporter: Jayush Luniya
>            Assignee: Jayush Luniya
>            Priority: Blocker
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-11990.patch
>
>
> For centos7 + HDP 2.3 ambari is using the centos6 HDP-UTILS. See here:
> https://github.com/apache/ambari/blob/trunk/ambari-server/src/main/resources/stacks/HDP/2.3/repos/repoinfo.xml

> Looks like that is an issue.
> {code}
> [root@ip-172-30-0-151 yum.repos.d]# more HDP-UTILS.repo 
> [HDP-UTILS-1.1.0.20]
> name=HDP-UTILS-1.1.0.20
> baseurl=http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.20/repos/centos6
> path=/
> enabled=1
> gpgcheck=0
> [root@ip-172-30-0-151 yum.repos.d]# /usr/bin/yum -y install snappy-devel
> Loaded plugins: amazon-id, rhui-lb
> Resolving Dependencies
> --> Running transaction check
> ---> Package snappy-devel.x86_64 0:1.0.5-1.el6 will be installed
> --> Processing Dependency: snappy(x86-64) = 1.0.5-1.el6 for package: snappy-devel-1.0.5-1.el6.x86_64
> --> Finished Dependency Resolution
> Error: Package: snappy-devel-1.0.5-1.el6.x86_64 (HDP-UTILS-1.1.0.20)
>            Requires: snappy(x86-64) = 1.0.5-1.el6
>            Installed: snappy-1.1.0-3.el7.x86_64 (@anaconda/7.1)
>                snappy(x86-64) = 1.1.0-3.el7
>            Available: snappy-1.0.5-1.el6.x86_64 (HDP-UTILS-1.1.0.20)
>                snappy(x86-64) = 1.0.5-1.el6
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message