ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-11884) Upgrade: error w/ ambari-server upgrade widgets
Date Fri, 12 Jun 2015 16:45:02 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-11884?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14583669#comment-14583669
] 

Hudson commented on AMBARI-11884:
---------------------------------

SUCCESS: Integrated in Ambari-trunk-Commit #2899 (See [https://builds.apache.org/job/Ambari-trunk-Commit/2899/])
AMBARI-11884. Upgrade: error w/ ambari-server upgrade widgets.(vbrodetskyi) (vbrodetskyi:
http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=fbbe77c3d760f8de57995fcb4cd29e3bd67c05a3)
* ambari-server/src/main/java/org/apache/ambari/server/controller/AmbariManagementControllerImpl.java
* ambari-server/src/main/java/org/apache/ambari/server/orm/dao/WidgetLayoutDAO.java


> Upgrade: error w/ ambari-server upgrade widgets
> -----------------------------------------------
>
>                 Key: AMBARI-11884
>                 URL: https://issues.apache.org/jira/browse/AMBARI-11884
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.1.0
>            Reporter: Vitaly Brodetskyi
>            Assignee: Vitaly Brodetskyi
>            Priority: Critical
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-11884.patch
>
>
> - Ambari 2.0.1 (embedded postgres), ambari-server non-root
> - installed hdp 2.2.6 cluster
> - upgraded to ambari 2.1.0 build #2081
> - "ambari-server upgrade" fails, exception in ambari-server.log
> {code}
> [root@c6402 conf]# ambari-server upgrade
> Using python  /usr/bin/python2.6
> Upgrading ambari-server
> Updating properties in ambari.properties ...
> Fixing database objects owner
> Upgrading database schema
> ERROR: Error executing schema upgrade, please check the server logs.
> ERROR: Ambari server upgrade failed. Please look at /var/log/ambari-server/ambari-server.log,
for more details.
> ERROR: Exiting with exit code 11. 
> REASON: Schema upgrade failed.
> {code}
> {code}
> Cluster' changed by: 'ambari-upgrade'; type='hadoop-env' tag='version1433989511704' from='version1'
> 11 Jun 2015 02:25:11,796  INFO [main] AbstractUpgradeCatalog:347 - Applying configuration
with tag 'version1433989511796' to cluster 'MyCluster'
> 11 Jun 2015 02:25:11,866  INFO [main] AbstractUpgradeCatalog:363 - cluster 'MyCluster'
changed by: 'ambari-upgrade'; type='core-site' tag='version1433989511796' from='version1'
> 11 Jun 2015 02:25:11,898 ERROR [main] SchemaUpgradeHelper:214 - Upgrade failed. 
> org.apache.ambari.server.AmbariException: Error creating stack widget artifacts. Cluster:
MyCluster
> 	at org.apache.ambari.server.controller.AmbariManagementControllerImpl.initializeWidgetsAndLayouts(AmbariManagementControllerImpl.java:4104)
> 	at org.apache.ambari.server.upgrade.UpgradeCatalog210.initializeClusterAndServiceWidgets(UpgradeCatalog210.java:747)
> 	at org.apache.ambari.server.upgrade.UpgradeCatalog210.executeDMLUpdates(UpgradeCatalog210.java:899)
> 	at org.apache.ambari.server.upgrade.AbstractUpgradeCatalog.upgradeData(AbstractUpgradeCatalog.java:433)
> 	at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.executeDMLUpdates(SchemaUpgradeHelper.java:212)
> 	at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.main(SchemaUpgradeHelper.java:280)
> Caused by: java.lang.IllegalArgumentException: Can not refresh not managed object: org.apache.ambari.server.orm.entities.WidgetLayoutEntity@1.
> 	at org.eclipse.persistence.internal.jpa.EntityManagerImpl.refresh(EntityManagerImpl.java:1024)
> 	at org.eclipse.persistence.internal.jpa.EntityManagerImpl.refresh(EntityManagerImpl.java:929)
> 	at org.apache.ambari.server.orm.dao.WidgetLayoutDAO.refresh(WidgetLayoutDAO.java:118)
> 	at org.apache.ambari.server.orm.AmbariJpaLocalTxnInterceptor.invoke(AmbariJpaLocalTxnInterceptor.java:68)
> 	at org.apache.ambari.server.controller.AmbariManagementControllerImpl.createWidgetsAndLayouts(AmbariManagementControllerImpl.java:4192)
> 	at org.apache.ambari.server.controller.AmbariManagementControllerImpl.initializeWidgetsAndLayouts(AmbariManagementControllerImpl.java:4100)
> 	... 5 more
> 11 Jun 2015 02:25:11,901 ERROR [main] SchemaUpgradeHelper:291 - Exception occurred during
upgrade, failed
> org.apache.ambari.server.AmbariException: Error creating stack widget artifacts. Cluster:
MyCluster
> 	at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.executeDMLUpdates(SchemaUpgradeHelper.java:215)
> 	at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.main(SchemaUpgradeHelper.java:280)
> Caused by: org.apache.ambari.server.AmbariException: Error creating stack widget artifacts.
Cluster: MyCluster
> 	at org.apache.ambari.server.controller.AmbariManagementControllerImpl.initializeWidgetsAndLayouts(AmbariManagementControllerImpl.java:4104)
> 	at org.apache.ambari.server.upgrade.UpgradeCatalog210.initializeClusterAndServiceWidgets(UpgradeCatalog210.java:747)
> 	at org.apache.ambari.server.upgrade.UpgradeCatalog210.executeDMLUpdates(UpgradeCatalog210.java:899)
> 	at org.apache.ambari.server.upgrade.AbstractUpgradeCatalog.upgradeData(AbstractUpgradeCatalog.java:433)
> 	at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.executeDMLUpdates(SchemaUpgradeHelper.java:212)
> 	... 1 more
> Caused by: java.lang.IllegalArgumentException: Can not refresh not managed object: org.apache.ambari.server.orm.entities.WidgetLayoutEntity@1.
> 	at org.eclipse.persistence.internal.jpa.EntityManagerImpl.refresh(EntityManagerImpl.java:1024)
> 	at org.eclipse.persistence.internal.jpa.EntityManagerImpl.refresh(EntityManagerImpl.java:929)
> 	at org.apache.ambari.server.orm.dao.WidgetLayoutDAO.refresh(WidgetLayoutDAO.java:118)
> 	at org.apache.ambari.server.orm.AmbariJpaLocalTxnInterceptor.invoke(AmbariJpaLocalTxnInterceptor.java:68)
> 	at org.apache.ambari.server.controller.AmbariManagementControllerImpl.createWidgetsAndLayouts(AmbariManagementControllerImpl.java:4192)
> 	at org.apache.ambari.server.controller.AmbariManagementControllerImpl.initializeWidgetsAndLayouts(AmbariManagementControllerImpl.java:4100)
> 	... 5 more
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message