ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-11872) Ambari Server need to check Java version on upgrade
Date Fri, 12 Jun 2015 12:29:00 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-11872?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14583332#comment-14583332
] 

Hudson commented on AMBARI-11872:
---------------------------------

SUCCESS: Integrated in Ambari-trunk-Commit #2896 (See [https://builds.apache.org/job/Ambari-trunk-Commit/2896/])
AMBARI-11872. Ambari Server need to check Java version on upgrade.(vbrodetskyi) (vbrodetskyi:
http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=6dbe315f9ab47fead66eeff5daea61dbfe8dee88)
* ambari-server/src/main/java/org/apache/ambari/server/configuration/Configuration.java
* ambari-server/src/main/java/org/apache/ambari/server/upgrade/SchemaUpgradeHelper.java


> Ambari Server need to check Java version on upgrade
> ---------------------------------------------------
>
>                 Key: AMBARI-11872
>                 URL: https://issues.apache.org/jira/browse/AMBARI-11872
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.1.0
>            Reporter: Vitaly Brodetskyi
>            Assignee: Vitaly Brodetskyi
>            Priority: Critical
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-11872.patch
>
>
> Since Ambari 2.1.0 we support Java 1.7.0 as minimal requirement and begin to use 1.7+
language constructions. Previously minimal language level was 1.6 and due to different reasons
user can miss notification about this change and can try to upgrade Ambari 2.0+ to Ambari
2.1 on Java 1.6, which will cause a lot of unexpected errors in different places.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message