ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vitaly Brodetskyi (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-11872) Ambari Server need to check Java version on upgrade
Date Fri, 12 Jun 2015 10:44:03 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-11872?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Vitaly Brodetskyi updated AMBARI-11872:
---------------------------------------
    Attachment: AMBARI-11872.patch

> Ambari Server need to check Java version on upgrade
> ---------------------------------------------------
>
>                 Key: AMBARI-11872
>                 URL: https://issues.apache.org/jira/browse/AMBARI-11872
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.1.0
>            Reporter: Vitaly Brodetskyi
>            Assignee: Vitaly Brodetskyi
>            Priority: Critical
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-11872.patch
>
>
> Since Ambari 2.1.0 we support Java 1.7.0 as minimal requirement and begin to use 1.7+
language constructions. Previously minimal language level was 1.6 and due to different reasons
user can miss notification about this change and can try to upgrade Ambari 2.0+ to Ambari
2.1 on Java 1.6, which will cause a lot of unexpected errors in different places.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message