ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alejandro Fernandez (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-11700) YarnTimelineServerStatePreservingCheck does not run when rolling upgrade a non-HDP stack
Date Wed, 10 Jun 2015 00:13:00 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-11700?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14579779#comment-14579779
] 

Alejandro Fernandez commented on AMBARI-11700:
----------------------------------------------

Pushed to branch-2.1 in commit c1a1d81c453ed2db8f558227f5a758d63aeff69a

> YarnTimelineServerStatePreservingCheck does not run when rolling upgrade a non-HDP stack
> ----------------------------------------------------------------------------------------
>
>                 Key: AMBARI-11700
>                 URL: https://issues.apache.org/jira/browse/AMBARI-11700
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.1.0
>            Reporter: Di Li
>            Assignee: Di Li
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-11700.patch
>
>
> The YarnTimelineServerStatePreservingCheck class skips running the check when the rolling
upgrade is for non-HDP stack, due to the comparison against hardcoded stack name "HDP" and
version value "2.2.4.2".
> The check may still need to run against a non-HDP stack. Use this JIRA to make the check
runnable based on properties (rollingupgrade.stack, rollingupgrade.version) set in the /etc/ambari-server/conf/ambari.properties.
Still default to HDP and 2.2.4.2 if the properties do not exist.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message