ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Lysnichenko (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-11695) Ambari RU should not perform 'yum install krb5-server' on ALL nodes during installing packages
Date Thu, 04 Jun 2015 16:42:38 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-11695?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmitry Lysnichenko updated AMBARI-11695:
----------------------------------------
    Attachment: AMBARI-11695.patch

> Ambari RU should not perform 'yum install krb5-server' on ALL nodes during installing
packages
> ----------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-11695
>                 URL: https://issues.apache.org/jira/browse/AMBARI-11695
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>            Reporter: Dmitry Lysnichenko
>            Assignee: Dmitry Lysnichenko
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-11695.patch
>
>
> During rolling upgrade in a secured cluster, ambari try to do 'yum install krb5-server'
on all the nodes.
> It is not the first similar issue, and hardcoding every package in install_packages.py
is a nightmare
> I've added a new tag skipUpgrade to service metainfo like:
> {code}
>             <package>
>               <name>ambari-metrics-collector</name>
>               <skipUpgrade>true</skipUpgrade>
>             </package>
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message