ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-11639) Ambari Admin View URL does not get properly parsed for custom versions
Date Wed, 03 Jun 2015 06:43:49 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-11639?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14570368#comment-14570368
] 

Hadoop QA commented on AMBARI-11639:
------------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12737081/0001-AMBARI-11639-Ambari-Admin-View-URL-does-not-get-prop.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in .

Test results: https://builds.apache.org/job/Ambari-trunk-test-patch/2995//testReport/
Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/2995//console

This message is automatically generated.

> Ambari Admin View URL does not get properly parsed for custom versions
> ----------------------------------------------------------------------
>
>                 Key: AMBARI-11639
>                 URL: https://issues.apache.org/jira/browse/AMBARI-11639
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-admin
>    Affects Versions: 2.1.0
>         Environment: RHEL 6.6
>            Reporter: Jesus Alvarez
>            Assignee: Jesus Alvarez
>         Attachments: 0001-AMBARI-11639-Ambari-Admin-View-URL-does-not-get-prop.patch
>
>   Original Estimate: 4h
>  Remaining Estimate: 4h
>
> When building a custom version of ADMIN VIEW jar with new version such as "2.1.0_custom",
the UI returns a 404 message upon redirect.
> Upon loading ambari-server (http://node1.bigdata:8080) for the first time, the URL is
redirected to:
> http://node1.bigdata:8080/views/ADMIN_VIEW/2.1.0_custom/INSTANCE/# , which returns a
404 missing page.
> If the URL is manually changed to http://node1.bigdata:8080/views/ADMIN_VIEW/2.1.0/INSTANCE/#
, the UI loads -- though links in ambari UI remain broken.
> This appears to be caused by 
> latestVersion = sortedMappedVersions[sortedMappedVersions.length-1];
> and ambari.service.load_server_version ; each parsing version string differently. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message