ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nate Cole" <nc...@hortonworks.com>
Subject Re: Review Request 35925: Ambari RU doesn't work with Redhat satellite
Date Fri, 26 Jun 2015 17:26:50 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/35925/#review89520
-----------------------------------------------------------

Ship it!



ambari-common/src/main/python/resource_management/core/providers/package/yumrpm.py (line 45)
<https://reviews.apache.org/r/35925/#comment142151>

    Shoud be .join(skip_repos) ?


- Nate Cole


On June 26, 2015, 1:23 p.m., Dmytro Sen wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/35925/
> -----------------------------------------------------------
> 
> (Updated June 26, 2015, 1:23 p.m.)
> 
> 
> Review request for Ambari, Dmitro Lisnichenko and Nate Cole.
> 
> 
> Bugs: AMBARI-12169
>     https://issues.apache.org/jira/browse/AMBARI-12169
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> PROBLEM: If the regular repository is not used, set up RH satellite and subscribed to
some particular channel for yum install, there is not repo file under /etc/yum.repos.d/, and
nothing can be put into the repository url in Ambari. This can be workaround, but when ambari
doing the RU, the command is:
> /usr/bin/yum -d 0 -e 0 -y install '--disablerepo=*' --enablerepo=base,HDP-UTILS-2.2.4.2,HDP-2.2.4.2
'hadoop_2_2_*'
> This will disable all the repository channels in the RH satellite. So the install will
fail.
> 
> After the patch all the packages are installed like
> 
> 2015-06-26 12:05:50,951 - Package['hadoop_2_2_*'] {'use_repos': ['HDP-2.2.6.0-2799',
'HDP-UTILS-2.2.6.0-2799']}
> 2015-06-26 12:05:50,952 - Installing package hadoop_2_2_* ('/usr/bin/yum -d 0 -e 0 -y
install '--disablerepo=HDP-*' --enablerepo=HDP-2.2.6.0-2799,HDP-UTILS-2.2.6.0-2799 'hadoop_2_2_*'')
> 
> 
> Diffs
> -----
> 
>   ambari-common/src/main/python/resource_management/core/providers/package/__init__.py
ad48b43 
>   ambari-common/src/main/python/resource_management/core/providers/package/apt.py c4cae2a

>   ambari-common/src/main/python/resource_management/core/providers/package/choco.py cd345fa

>   ambari-common/src/main/python/resource_management/core/providers/package/yumrpm.py
c17b7f0 
>   ambari-common/src/main/python/resource_management/core/providers/package/zypper.py
dd16ce0 
>   ambari-common/src/main/python/resource_management/core/resources/packaging.py 4e8c9fc

>   ambari-server/src/main/resources/custom_actions/scripts/install_packages.py 0681afe

>   ambari-server/src/test/python/custom_actions/TestInstallPackages.py 6badfd1 
> 
> Diff: https://reviews.apache.org/r/35925/diff/
> 
> 
> Testing
> -------
> 
> ----------------------------------------------------------------------
> Ran 268 tests in 8.991s
> 
> OK
> ----------------------------------------------------------------------
> Total run:797
> Total errors:0
> Total failures:0
> OK
> 
> 
> Thanks,
> 
> Dmytro Sen
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message