ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nate Cole" <nc...@hortonworks.com>
Subject Re: Review Request 35352: AMBARI-11810: Rolling upgrade does not run pre-upgrade checks against non-HDP stack
Date Fri, 26 Jun 2015 13:35:38 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/35352/#review89495
-----------------------------------------------------------


This code change was worked on recently by another engineer.  You should pull and see if this
still applies.

- Nate Cole


On June 24, 2015, 2:32 p.m., Di Li wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/35352/
> -----------------------------------------------------------
> 
> (Updated June 24, 2015, 2:32 p.m.)
> 
> 
> Review request for Ambari, Alejandro Fernandez, Jonathan Hurley, and Nate Cole.
> 
> 
> Bugs: AMBARI-11810
>     https://issues.apache.org/jira/browse/AMBARI-11810
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> All the rolling upgrade pre-checks may still need to run against a non-HDP stack. Use
this JIRA to make the check runnable based on properties (rollingupgrade.stack, rollingupgrade.version)
set in the /etc/ambari-server/conf/ambari.properties. Still default to HDP and 2.2.4.2 if
the properties do not exist.
> 
> org.apache.ambari.server.checks.AbstractCheckDescriptor compares stack against hardcoded
StackInfo "HDP-2.2". the stack name and version info can be externalized into the /etc/ambari-server/conf/ambar.properties
in order to support non-HDP stacks.
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/java/org/apache/ambari/server/checks/AbstractCheckDescriptor.java
8cabf29 
>   ambari-server/src/test/java/org/apache/ambari/server/checks/AbstractCheckDescriptorTest.java
4834cee 
> 
> Diff: https://reviews.apache.org/r/35352/diff/
> 
> 
> Testing
> -------
> 
> Added new unit tests
> 
> Manually tested the fix by kicking off the rolling upgrade
> 1. With no properties in /etc/ambari-server/conf/ambari.properties, Java code used the
default HDP-2.2 StackId information and performed the upgrade pre-checks.
> 2. With wrong property values in ambari.properties, Java code threw err about the StackId
did not match
> 3. With correct property values in ambari.properties, Java code used the stack id and
performed the upgrade pre-checks.
> 
> 
> Thanks,
> 
> Di Li
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message