ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Levas" <rle...@hortonworks.com>
Subject Review Request 35518: Kerberos Wizard: Moving between steps 2 and 3 back/forward cause API error.
Date Tue, 16 Jun 2015 14:21:00 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/35518/
-----------------------------------------------------------

Review request for Ambari, Aleksandr Kovalenko, Andrii Tkach, Jaimin Jetly, and Yusaku Sako.


Bugs: AMBARI-11949
    https://issues.apache.org/jira/browse/AMBARI-11949


Repository: ambari


Description
-------

STR:
* Install cluster with HDFS, Hive and dependcies.
* Start Kerberos Wizard
* Proceed to step 3 *Install and Test Kerberos Client*
* Go back to step2 *Configure Kerberos*
* Click on next button

AR: Popup with request error shown
```
500 status code recieved on POST method for API: /api/v1/clusters/c1/hosts

Error message: org.apache.ambari.server.controller.spi.SystemException: An internal system
exception occurred: ServiceComponent not found, clusterName=c1, serviceName=KERBEROS, serviceComponentName=KERBEROS_CLIENT
```

After popup confirmation click on Next button doesn't do anything.
ER: No errors shown, user can proceed to the next step.

Workaround: Refresh page on step2 and hit Next button.


Diffs
-----

  ambari-web/app/controllers/main/admin/kerberos/step2_controller.js a34dc30 

Diff: https://reviews.apache.org/r/35518/diff/


Testing
-------

Manually tested
Local unit tests ran

#Jenkins test results: PENDING


Thanks,

Robert Levas


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message