ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vitalyi Brodetskyi" <vbrodets...@hortonworks.com>
Subject Review Request 35381: Ambari Server need to check Java version on upgrade
Date Fri, 12 Jun 2015 10:45:08 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/35381/
-----------------------------------------------------------

Review request for Ambari and Dmitro Lisnichenko.


Bugs: AMBARI-11872
    https://issues.apache.org/jira/browse/AMBARI-11872


Repository: ambari


Description
-------

Since Ambari 2.1.0 we support Java 1.7.0 as minimal requirement and begin to use 1.7+ language
constructions. Previously minimal language level was 1.6 and due to different reasons user
can miss notification about this change and can try to upgrade Ambari 2.0+ to Ambari 2.1 on
Java 1.6, which will cause a lot of unexpected errors in different places.


Diffs
-----

  ambari-server/src/main/java/org/apache/ambari/server/configuration/Configuration.java dc6089a

  ambari-server/src/main/java/org/apache/ambari/server/upgrade/SchemaUpgradeHelper.java f1ff33f


Diff: https://reviews.apache.org/r/35381/diff/


Testing
-------

mvn clean test


Thanks,

Vitalyi Brodetskyi


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message