ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Nettleton" <rnettle...@hortonworks.com>
Subject Re: Review Request 35190: Invalid property value set in core-site.xml when KNOX HA is enabled
Date Mon, 08 Jun 2015 00:54:22 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/35190/#review86976
-----------------------------------------------------------

Ship it!


Ship It!

- Robert Nettleton


On June 7, 2015, 8:42 p.m., Robert Levas wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/35190/
> -----------------------------------------------------------
> 
> (Updated June 7, 2015, 8:42 p.m.)
> 
> 
> Review request for Ambari, Emil Anca, Jaimin Jetly, Robert Nettleton, and Tom Beerbower.
> 
> 
> Bugs: AMBARI-11753
>     https://issues.apache.org/jira/browse/AMBARI-11753
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> In KNOX-HA cluster, noticed that the “hadoop.proxyuser.knox.hosts" property in /etc/hadoop/conf/core-site.xml
>  refers to only one node and knox is running on multiple nodes.
> ```
>  <property>
>       <name>hadoop.proxyuser.knox.hosts</name>
>       <value>host1</value>
>     </property>
> ```
> The value for this property should include all the knox hosts
> ```
>  <property>
>       <name>hadoop.proxyuser.knox.hosts</name>
>       <value>host1,host4,etc...</value>
>     </property>
> ```
> 
> #Solution
> - Updated KNOX kerberos.json file to set relevant  core-site, webhcat-site, and oozie-site
configrations
> - Fixed backend to produce the correct set of data in the `clusterHostInfo` data set
> - Moved org.apache.ambari.server.controller.internal.ClientConfigResourceProvider#substituteHostIndexes
(and supporting methods) to org.apache.ambari.server.utils.StageUtils#substituteHostIndexes
> - Renamed org.apache.ambari.server.utils.TestStageUtils to org.apache.ambari.server.utils.StageUtilsTest
for consistency
> - Fixed and enabled (the previously ignored) `testGetClusterHostInfo` test, other ignored
tests were lefts as is (and probably broken)
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/java/org/apache/ambari/server/controller/KerberosHelperImpl.java
76054b7 
>   ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ClientConfigResourceProvider.java
2db2d28 
>   ambari-server/src/main/java/org/apache/ambari/server/utils/StageUtils.java aeca69b

>   ambari-server/src/main/resources/common-services/KNOX/0.5.0.2.2/kerberos.json 584a932

>   ambari-server/src/test/java/org/apache/ambari/server/controller/KerberosHelperTest.java
5744b53 
>   ambari-server/src/test/java/org/apache/ambari/server/utils/StageUtilsTest.java PRE-CREATION

>   ambari-server/src/test/java/org/apache/ambari/server/utils/TestStageUtils.java 8b6d2ae

> 
> Diff: https://reviews.apache.org/r/35190/diff/
> 
> 
> Testing
> -------
> 
> Manually tested
> Updated and successfully ran org.apache.ambari.server.utils.StageUtilsTest
> All ambari-server test ran locally
> 
> #Jenkins test results: PENDING
> 
> 
> Thanks,
> 
> Robert Levas
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message