ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Speidel" <jspei...@hortonworks.com>
Subject Re: Review Request 35151: BP Host Group properties are not being applied to configuration properly
Date Fri, 05 Jun 2015 21:25:31 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/35151/
-----------------------------------------------------------

(Updated June 5, 2015, 9:25 p.m.)


Review request for Ambari and Robert Nettleton.


Bugs: AMBARI-11737
    https://issues.apache.org/jira/browse/AMBARI-11737


Repository: ambari


Description
-------

Configurations specified in a blueprint host group are not applied to configuration is some
cases.


Diffs
-----

  ambari-server/src/main/java/org/apache/ambari/server/controller/internal/BlueprintConfigurationProcessor.java
ababc29 
  ambari-server/src/main/java/org/apache/ambari/server/controller/internal/Stack.java ba01d68

  ambari-server/src/main/java/org/apache/ambari/server/topology/AmbariContext.java 0de4b00

  ambari-server/src/main/java/org/apache/ambari/server/topology/Configuration.java 2447b8b

  ambari-server/src/main/java/org/apache/ambari/server/topology/RequiredPasswordValidator.java
252b78b 
  ambari-server/src/test/java/org/apache/ambari/server/controller/internal/BlueprintConfigurationProcessorTest.java
83ed594 
  ambari-server/src/test/java/org/apache/ambari/server/controller/internal/StackTest.java
a8b466d 
  ambari-server/src/test/java/org/apache/ambari/server/topology/AmbariContextTest.java 7dcb7be

  ambari-server/src/test/java/org/apache/ambari/server/topology/ConfigurationTest.java PRE-CREATION

  ambari-server/src/test/java/org/apache/ambari/server/topology/RequiredPasswordValidatorTest.java
bc23b35 

Diff: https://reviews.apache.org/r/35151/diff/


Testing (updated)
-------

Functional Tests:
- Created several clusters via the API which contain BP Host Group configuration
- Note: I am seeing failures when starting HIVE_METASTORE which I believe to be related to
an unrelated known issue. I am trying to confirm this now. 

** I have reproduced this with a clean trunk build **

Unit Tests:
- Added new tests
- All existing unit tests pass except for one unrelated python test

Results :

Tests run: 3060, Failures: 0, Errors: 0, Skipped: 29
...
----------------------------------------------------------------------
Total run:751
Total errors:0
Total failures:1

Failed tests:
FAIL: test_socket_timeout (test_hive_server.TestHiveServer


Thanks,

John Speidel


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message