ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMBARI-11063) Can not upgrade ambari 2.0.0->2.0.1 on sles113
Date Tue, 12 May 2015 12:24:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-11063?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Onischuk resolved AMBARI-11063.
--------------------------------------
    Resolution: Fixed

Committed to branch-2.0.maint

> Can not upgrade ambari 2.0.0->2.0.1 on sles113
> ----------------------------------------------
>
>                 Key: AMBARI-11063
>                 URL: https://issues.apache.org/jira/browse/AMBARI-11063
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 2.0.1
>
>
> STR:  
> 1) Install Ambari 2.0.0, stack 2.2 with default options  
> 2) Ambari-only upgrade  
> Results:  
> ambari-server upgrade failed:
>     
>     
>     08 May 2015 08:46:24,771  INFO [main] Configuration:527 - Reading password from existing
file
>     08 May 2015 08:46:24,789  INFO [main] Configuration:747 - Hosts Mapping File null
>     08 May 2015 08:46:24,789  INFO [main] HostsMap:60 - Using hostsmap file null
>     08 May 2015 08:46:25,435  INFO [main] ControllerModule:173 - Detected POSTGRES as
the database type from the JDBC URL
>     08 May 2015 08:46:31,576  INFO [main] SchemaUpgradeHelper:231 - Upgrading schema
to target version = 2.0.1
>     08 May 2015 08:46:31,615  INFO [main] SchemaUpgradeHelper:240 - Upgrading schema
from source version = 2.0.0
>     08 May 2015 08:46:31,621  INFO [main] SchemaUpgradeHelper:147 - Upgrade path: [{
upgradeCatalog: sourceVersion = 1.7.0, targetVersion = 2.0.1 }]
>     08 May 2015 08:46:31,622  INFO [main] SchemaUpgradeHelper:180 - Executing DDL upgrade...
>     08 May 2015 08:46:31,622  INFO [main] DBAccessorImpl:547 - Executing query: ALTER
SCHEMA ambari OWNER TO "ambari";
>     08 May 2015 08:46:31,623  INFO [main] DBAccessorImpl:547 - Executing query: ALTER
ROLE "ambari" SET search_path to 'ambari';
>     08 May 2015 08:46:31,632  INFO [main] DBAccessorImpl:547 - Executing query: INSERT
INTO ambari_sequences(sequence_name, sequence_value) VALUES('repo_version_id_seq', 0)
>     08 May 2015 08:46:31,635 ERROR [main] DBAccessorImpl:553 - Error executing query:
INSERT INTO ambari_sequences(sequence_name, sequence_value) VALUES('repo_version_id_seq',
0)
>     org.postgresql.util.PSQLException: ERROR: duplicate key value violates unique constraint
"ambari_sequences_pkey"
>     	at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2161)
>     	at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1890)
>     	at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:255)
>     	at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:559)
>     	at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:403)
>     	at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:395)
>     	at org.apache.ambari.server.orm.DBAccessorImpl.executeQuery(DBAccessorImpl.java:550)
>     	at org.apache.ambari.server.upgrade.UpgradeCatalog200.prepareRollingUpgradesDDL(UpgradeCatalog200.java:204)
>     	at org.apache.ambari.server.upgrade.UpgradeCatalog200.executeDDLUpdates(UpgradeCatalog200.java:123)
>     	at org.apache.ambari.server.upgrade.AbstractUpgradeCatalog.upgradeSchema(AbstractUpgradeCatalog.java:371)
>     	at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.executeUpgrade(SchemaUpgradeHelper.java:185)
>     	at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.main(SchemaUpgradeHelper.java:245)
>     08 May 2015 08:46:31,638 ERROR [main] SchemaUpgradeHelper:187 - Upgrade failed. 
>     org.postgresql.util.PSQLException: ERROR: duplicate key value violates unique constraint
"ambari_sequences_pkey"
>     	at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2161)
>     	at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1890)
>     	at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:255)
>     	at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:559)
>     	at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:403)
>     	at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:395)
>     	at org.apache.ambari.server.orm.DBAccessorImpl.executeQuery(DBAccessorImpl.java:550)
>     	at org.apache.ambari.server.upgrade.UpgradeCatalog200.prepareRollingUpgradesDDL(UpgradeCatalog200.java:204)
>     	at org.apache.ambari.server.upgrade.UpgradeCatalog200.executeDDLUpdates(UpgradeCatalog200.java:123)
>     	at org.apache.ambari.server.upgrade.AbstractUpgradeCatalog.upgradeSchema(AbstractUpgradeCatalog.java:371)
>     	at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.executeUpgrade(SchemaUpgradeHelper.java:185)
>     	at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.main(SchemaUpgradeHelper.java:245)
>     08 May 2015 08:46:31,643 ERROR [main] SchemaUpgradeHelper:258 - Exception occured
during upgrade, failed
>     org.apache.ambari.server.AmbariException: ERROR: duplicate key value violates unique
constraint "ambari_sequences_pkey"
>     	at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.executeUpgrade(SchemaUpgradeHelper.java:188)
>     	at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.main(SchemaUpgradeHelper.java:245)
>     Caused by: org.postgresql.util.PSQLException: ERROR: duplicate key value violates
unique constraint "ambari_sequences_pkey"
>     	at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2161)
>     	at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1890)
>     	at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:255)
>     	at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:559)
>     	at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:403)
>     	at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:395)
>     	at org.apache.ambari.server.orm.DBAccessorImpl.executeQuery(DBAccessorImpl.java:550)
>     	at org.apache.ambari.server.upgrade.UpgradeCatalog200.prepareRollingUpgradesDDL(UpgradeCatalog200.java:204)
>     	at org.apache.ambari.server.upgrade.UpgradeCatalog200.executeDDLUpdates(UpgradeCatalog200.java:123)
>     	at org.apache.ambari.server.upgrade.AbstractUpgradeCatalog.upgradeSchema(AbstractUpgradeCatalog.java:371)
>     	at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.executeUpgrade(SchemaUpgradeHelper.java:185)
>     	... 1 more
>     
>     



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message