ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley" <jhur...@hortonworks.com>
Subject Re: Review Request 34246: Upgrade Is Allowed When A Service Is Installed After Distribute Repositories
Date Fri, 15 May 2015 03:54:19 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/34246/#review83892
-----------------------------------------------------------

Ship it!


Just a minor comment; I think we can use StackId equality comparison directly here. If I'm
wrong then just close the issue I opened.


ambari-server/src/main/java/org/apache/ambari/server/events/listeners/upgrade/HostVersionOutOfSyncListener.java
<https://reviews.apache.org/r/34246/#comment134972>

    StackId implements equals() ... no need to convert them to strings, right?


- Jonathan Hurley


On May 14, 2015, 8:29 p.m., Alejandro Fernandez wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/34246/
> -----------------------------------------------------------
> 
> (Updated May 14, 2015, 8:29 p.m.)
> 
> 
> Review request for Ambari, Dmitro Lisnichenko, Jonathan Hurley, and Nate Cole.
> 
> 
> Bugs: AMBARI-11146
>     https://issues.apache.org/jira/browse/AMBARI-11146
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> was done before the service was added.
> 
> STR:
> * Install base services like HDFS and YARN
> * Distribute new repository
> * Install HBase
> * Attempt upgrade
> 
> At this point two things should happen:
> The web client should not allow the upgrade to happen
> The pre-upgrade check HostsRepositoryVersionCheck should prevent the upgrade.
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/java/org/apache/ambari/server/events/listeners/upgrade/HostVersionOutOfSyncListener.java
8c8f978 
>   ambari-server/src/test/java/org/apache/ambari/server/events/listeners/upgrade/HostVersionOutOfSyncListenerTest.java
aa8b860 
>   ambari-server/src/test/java/org/apache/ambari/server/utils/EventBusSynchronizer.java
4b0c031 
> 
> Diff: https://reviews.apache.org/r/34246/diff/
> 
> 
> Testing
> -------
> 
> mvn clean test
> 
> Reproduced the issue on a local cluster, and verified that the fix worked by Installing
a new version, then adding a service, which marked the host_version and single cluster_version
record as OUT_OF_SYNC.
> 
> 
> Thanks,
> 
> Alejandro Fernandez
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message