ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-10811) Blueprints containing HA components or implicit MYSQL_SERVER components fail to provision
Date Wed, 29 Apr 2015 02:17:06 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-10811?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14518584#comment-14518584
] 

Hudson commented on AMBARI-10811:
---------------------------------

SUCCESS: Integrated in Ambari-trunk-Commit #2467 (See [https://builds.apache.org/job/Ambari-trunk-Commit/2467/])
AMBARI-10811. Fix issues with config topology update in certain topologies (jspeidel: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=43ae930b0188f22913dcc67ec5c8ea168ff4deae)
* ambari-server/src/main/java/org/apache/ambari/server/topology/ClusterConfigurationRequest.java
* ambari-server/src/test/java/org/apache/ambari/server/controller/internal/BlueprintConfigurationProcessorTest.java
* ambari-server/src/main/java/org/apache/ambari/server/topology/TopologyManager.java
* ambari-server/src/main/java/org/apache/ambari/server/controller/internal/BlueprintConfigurationProcessor.java


> Blueprints containing HA components or implicit MYSQL_SERVER components fail to provision
> -----------------------------------------------------------------------------------------
>
>                 Key: AMBARI-10811
>                 URL: https://issues.apache.org/jira/browse/AMBARI-10811
>             Project: Ambari
>          Issue Type: Bug
>          Components: blueprints
>    Affects Versions: Ambari-2.1
>            Reporter: John Speidel
>            Assignee: John Speidel
>            Priority: Blocker
>             Fix For: Ambari-2.1
>
>
> When provisioning a cluster using a blueprint that contains HA components or an existing
MYSQL_SERVER or implicit MYSQL_SERVER (not explicitly specified in blueprint but required
by dependency) the cluster fails to deploy.
> The request remains in the PENDING state and at 0% complete.
> Output like the following is logged to ambari-server.out:
> {code}
> TopologyManager.ConfigureClusterTask: Entering
> Caught an error from Config Processor: java.lang.IllegalArgumentException: Unable to
determine required host groups for component. Component 'MYSQL_SERVER' is not mapped to any
host group or is mapped to multiple groups.
> {code}
> This is a regression as a result of  https://issues.apache.org/jira/browse/AMBARI-10750
> The problem was that the blueprint config processor was not dealing with these topologies
properly when trying to determine which host groups needed to be resolved prior to updating
configuration.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message