ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-10784) Create widget -> Add metric popup: Aggregator Function name should be suffixed to the metric name
Date Tue, 28 Apr 2015 12:42:06 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-10784?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14516966#comment-14516966
] 

Hudson commented on AMBARI-10784:
---------------------------------

FAILURE: Integrated in Ambari-trunk-Commit #2458 (See [https://builds.apache.org/job/Ambari-trunk-Commit/2458/])
AMBARI-10784 Create widget -> Add metric popup: Aggregator Function name should be suffixed
to the metric name. (atkach) (atkach: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=2d917162314487f002610b5e0675380fbc26b66f)
* ambari-web/app/views/main/service/widgets/create/expression_view.js


> Create widget -> Add metric popup: Aggregator Function name should be suffixed to
the metric name
> -------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-10784
>                 URL: https://issues.apache.org/jira/browse/AMBARI-10784
>             Project: Ambari
>          Issue Type: Task
>          Components: ambari-web
>    Affects Versions: 2.1.0
>            Reporter: Andrii Tkach
>            Assignee: Andrii Tkach
>            Priority: Critical
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-10784.patch
>
>
> If user selects any option other than avg, metric name along with metric path should
be suffixed with ._$\{aggregator function name\}. In such case selected metric name should
show along with the suffix (aggregator function name) in expression builder box.
> *NOTE:* 
> * After this work metric name is no longer unique and can correspond to any of $\{metric
path\} or $\{metric_path\}._min or $\{metric_path\}._max or $\{metric_path\}._sum. We require
a unique metric name for each metric path.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message