ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-10784) Create widget -> Add metric popup: Aggregator Function name should be suffixed to the metric name
Date Tue, 28 Apr 2015 11:12:05 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-10784?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14516820#comment-14516820
] 

Hadoop QA commented on AMBARI-10784:
------------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12728751/AMBARI-10784.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in .

Test results: https://builds.apache.org/job/Ambari-trunk-test-patch/2541//testReport/
Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/2541//console

This message is automatically generated.

> Create widget -> Add metric popup: Aggregator Function name should be suffixed to
the metric name
> -------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-10784
>                 URL: https://issues.apache.org/jira/browse/AMBARI-10784
>             Project: Ambari
>          Issue Type: Task
>          Components: ambari-web
>    Affects Versions: 2.1.0
>            Reporter: Andrii Tkach
>            Assignee: Andrii Tkach
>            Priority: Critical
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-10784.patch
>
>
> If user selects any option other than avg, metric name along with metric path should
be suffixed with ._$\{aggregator function name\}. In such case selected metric name should
show along with the suffix (aggregator function name) in expression builder box.
> *NOTE:* 
> * After this work metric name is no longer unique and can correspond to any of $\{metric
path\} or $\{metric_path\}._min or $\{metric_path\}._max or $\{metric_path\}._sum. We require
a unique metric name for each metric path.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message