ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrii Tkach (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-10784) Create widget -> Add metric popup: Aggregator Function name should be suffixed to the metric name
Date Tue, 28 Apr 2015 10:17:06 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-10784?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14516763#comment-14516763
] 

Andrii Tkach commented on AMBARI-10784:
---------------------------------------

  5920 tests complete (11 seconds)
  79 tests pending

> Create widget -> Add metric popup: Aggregator Function name should be suffixed to
the metric name
> -------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-10784
>                 URL: https://issues.apache.org/jira/browse/AMBARI-10784
>             Project: Ambari
>          Issue Type: Task
>          Components: ambari-web
>    Affects Versions: 2.1.0
>            Reporter: Andrii Tkach
>            Assignee: Andrii Tkach
>            Priority: Critical
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-10784.patch
>
>
> If user selects any option other than avg, metric name along with metric path should
be suffixed with ._$\{aggregator function name\}. In such case selected metric name should
show along with the suffix (aggregator function name) in expression builder box.
> *NOTE:* 
> * After this work metric name is no longer unique and can correspond to any of $\{metric
path\} or $\{metric_path\}._min or $\{metric_path\}._max or $\{metric_path\}._sum. We require
a unique metric name for each metric path.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message