ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mahan Hosseinzadeh (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-10615) Ambari 2.0 install packages (new version) stuck in case of any error
Date Mon, 20 Apr 2015 23:14:58 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-10615?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mahan Hosseinzadeh updated AMBARI-10615:
----------------------------------------
    Description: 
After registering version HDP-2.2.4.2, packages have been installed on all hosts but one!
The Ambari operation is "Install version" and the host failed task called "Install Packages"
There is no way to rerun the package installation on 1 specific host or in worst case deregister
the new version which hasn't upgraded the old one.
The upgrade is stuck on Installing and there is no progress even by restarting the ambari-server
due to the following error:

2015-04-20 16:46:30,022 - call['hdp-select versions'] {}
2015-04-20 16:46:30,101 - u"Repository['HDP-UTILS-2.2.4.2']" {'append_to_file': False, 'base_url':
'http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.20/repos/centos6', 'action': ['create'],
'components': [u'HDP-UTILS', 'main'], 'repo_template': 'repo_suse_rhel.j2', 'repo_file_name':
'HDP-2.2.4.2', 'mirror_list': None}
2015-04-20 16:46:30,112 - u"File['/etc/yum.repos.d/HDP-2.2.4.2.repo']" {'content': Template('repo_suse_rhel.j2')}
2015-04-20 16:46:30,390 - Writing u"File['/etc/yum.repos.d/HDP-2.2.4.2.repo']" because it
doesn't exist
2015-04-20 16:46:30,697 - u"Repository['HDP-2.2.4.2']" {'append_to_file': True, 'base_url':
'http://public-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.2.4.2', 'action': ['create'],
'components': [u'HDP', 'main'], 'repo_template': 'repo_suse_rhel.j2', 'repo_file_name': 'HDP-2.2.4.2',
'mirror_list': None}
2015-04-20 16:46:31,236 - u"Package['kafka_2_2_*']" {'use_repos': ['base', 'HDP-UTILS-2.2.4.2',
'HDP-2.2.4.2']}
2015-04-20 16:46:32,549 - Installing package kafka_2_2_* ('/usr/bin/yum -d 0 -e 0 -y install
'--disablerepo=*' --enablerepo=base,HDP-UTILS-2.2.4.2,HDP-2.2.4.2 'kafka_2_2_*'')
2015-04-20 16:46:58,296 - u"Package['pig_2_2_*']" {'use_repos': ['base', 'HDP-UTILS-2.2.4.2',
'HDP-2.2.4.2']}
2015-04-20 16:46:59,212 - Installing package pig_2_2_* ('/usr/bin/yum -d 0 -e 0 -y install
'--disablerepo=*' --enablerepo=base,HDP-UTILS-2.2.4.2,HDP-2.2.4.2 'pig_2_2_*'')
Can not install packages.
Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 97,
in actionexecute
    Package(name, use_repos=list(current_repo_files) if OSCheck.is_ubuntu_family() else current_repositories)
  File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 148, in __init__
    self.env.run()
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 152,
in run
    self.run_action(resource, action)
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 118,
in run_action
    provider_action()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py",
line 43, in action_install
    self.install_package(package_name, self.resource.use_repos)
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py",
line 51, in install_package
    shell.checked_call(cmd, sudo=True, logoutput=self.get_logoutput())
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70, in inner
    return function(command, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 82, in checked_call
    return _call(command, logoutput, True, cwd, env, preexec_fn, user, wait_for_finish, timeout,
path, sudo, on_new_line)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 199, in
_call
    raise Fail(err_msg)
Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install '--disablerepo=*' --enablerepo=base,HDP-UTILS-2.2.4.2,HDP-2.2.4.2
'pig_2_2_*'' returned 1. 

Transaction Check Error:
  installing package hadoop_2_2_4_2_2-2.6.0.2.2.4.2-2.el6.x86_64 needs 194MB on the / filesystem
  installing package hadoop_2_2_4_2_2-client-2.6.0.2.2.4.2-2.el6.x86_64 needs 194MB on the
/ filesystem

Error Summary
-------------
Disk Requirements:
  At least 194MB more space needed on the / filesystem.


2015-04-20 16:56:24,794 - u"Package['kafka_2_2_4_2_2.noarch']" {'action': ['remove']}
2015-04-20 16:56:25,329 - Removing package kafka_2_2_4_2_2.noarch ('/usr/bin/yum -d 0 -e 0
-y erase kafka_2_2_4_2_2.noarch')
2015-04-20 16:56:27,067 - u"Package['zookeeper_2_2_4_2_2.noarch']" {'action': ['remove']}
2015-04-20 16:56:27,601 - Removing package zookeeper_2_2_4_2_2.noarch ('/usr/bin/yum -d 0
-e 0 -y erase zookeeper_2_2_4_2_2.noarch')
2015-04-20 16:56:29,300 - Error while executing command 'actionexecute':
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 214, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 139,
in actionexecute
    raise Fail("Failed to distribute repositories/install packages")
Fail: Failed to distribute repositories/install packages

  was:
After registering version HDP-2.2.4.2, packages have been installed on all hosts but one!
The Ambari operation is "Install version" and the host failed task called "Install Packages"
The upgrade is stuck on Installing and there is no progress even by restarting the ambari-server
due to the following error:

2015-04-20 16:46:30,022 - call['hdp-select versions'] {}
2015-04-20 16:46:30,101 - u"Repository['HDP-UTILS-2.2.4.2']" {'append_to_file': False, 'base_url':
'http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.20/repos/centos6', 'action': ['create'],
'components': [u'HDP-UTILS', 'main'], 'repo_template': 'repo_suse_rhel.j2', 'repo_file_name':
'HDP-2.2.4.2', 'mirror_list': None}
2015-04-20 16:46:30,112 - u"File['/etc/yum.repos.d/HDP-2.2.4.2.repo']" {'content': Template('repo_suse_rhel.j2')}
2015-04-20 16:46:30,390 - Writing u"File['/etc/yum.repos.d/HDP-2.2.4.2.repo']" because it
doesn't exist
2015-04-20 16:46:30,697 - u"Repository['HDP-2.2.4.2']" {'append_to_file': True, 'base_url':
'http://public-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.2.4.2', 'action': ['create'],
'components': [u'HDP', 'main'], 'repo_template': 'repo_suse_rhel.j2', 'repo_file_name': 'HDP-2.2.4.2',
'mirror_list': None}
2015-04-20 16:46:31,236 - u"Package['kafka_2_2_*']" {'use_repos': ['base', 'HDP-UTILS-2.2.4.2',
'HDP-2.2.4.2']}
2015-04-20 16:46:32,549 - Installing package kafka_2_2_* ('/usr/bin/yum -d 0 -e 0 -y install
'--disablerepo=*' --enablerepo=base,HDP-UTILS-2.2.4.2,HDP-2.2.4.2 'kafka_2_2_*'')
2015-04-20 16:46:58,296 - u"Package['pig_2_2_*']" {'use_repos': ['base', 'HDP-UTILS-2.2.4.2',
'HDP-2.2.4.2']}
2015-04-20 16:46:59,212 - Installing package pig_2_2_* ('/usr/bin/yum -d 0 -e 0 -y install
'--disablerepo=*' --enablerepo=base,HDP-UTILS-2.2.4.2,HDP-2.2.4.2 'pig_2_2_*'')
Can not install packages.
Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 97,
in actionexecute
    Package(name, use_repos=list(current_repo_files) if OSCheck.is_ubuntu_family() else current_repositories)
  File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 148, in __init__
    self.env.run()
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 152,
in run
    self.run_action(resource, action)
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 118,
in run_action
    provider_action()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py",
line 43, in action_install
    self.install_package(package_name, self.resource.use_repos)
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py",
line 51, in install_package
    shell.checked_call(cmd, sudo=True, logoutput=self.get_logoutput())
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70, in inner
    return function(command, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 82, in checked_call
    return _call(command, logoutput, True, cwd, env, preexec_fn, user, wait_for_finish, timeout,
path, sudo, on_new_line)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 199, in
_call
    raise Fail(err_msg)
Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install '--disablerepo=*' --enablerepo=base,HDP-UTILS-2.2.4.2,HDP-2.2.4.2
'pig_2_2_*'' returned 1. 

Transaction Check Error:
  installing package hadoop_2_2_4_2_2-2.6.0.2.2.4.2-2.el6.x86_64 needs 194MB on the / filesystem
  installing package hadoop_2_2_4_2_2-client-2.6.0.2.2.4.2-2.el6.x86_64 needs 194MB on the
/ filesystem

Error Summary
-------------
Disk Requirements:
  At least 194MB more space needed on the / filesystem.


2015-04-20 16:56:24,794 - u"Package['kafka_2_2_4_2_2.noarch']" {'action': ['remove']}
2015-04-20 16:56:25,329 - Removing package kafka_2_2_4_2_2.noarch ('/usr/bin/yum -d 0 -e 0
-y erase kafka_2_2_4_2_2.noarch')
2015-04-20 16:56:27,067 - u"Package['zookeeper_2_2_4_2_2.noarch']" {'action': ['remove']}
2015-04-20 16:56:27,601 - Removing package zookeeper_2_2_4_2_2.noarch ('/usr/bin/yum -d 0
-e 0 -y erase zookeeper_2_2_4_2_2.noarch')
2015-04-20 16:56:29,300 - Error while executing command 'actionexecute':
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 214, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 139,
in actionexecute
    raise Fail("Failed to distribute repositories/install packages")
Fail: Failed to distribute repositories/install packages


> Ambari 2.0 install packages (new version) stuck in case of any error
> --------------------------------------------------------------------
>
>                 Key: AMBARI-10615
>                 URL: https://issues.apache.org/jira/browse/AMBARI-10615
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-web
>    Affects Versions: 2.0.0
>            Reporter: Mahan Hosseinzadeh
>            Priority: Blocker
>
> After registering version HDP-2.2.4.2, packages have been installed on all hosts but
one!
> The Ambari operation is "Install version" and the host failed task called "Install Packages"
> There is no way to rerun the package installation on 1 specific host or in worst case
deregister the new version which hasn't upgraded the old one.
> The upgrade is stuck on Installing and there is no progress even by restarting the ambari-server
due to the following error:
> 2015-04-20 16:46:30,022 - call['hdp-select versions'] {}
> 2015-04-20 16:46:30,101 - u"Repository['HDP-UTILS-2.2.4.2']" {'append_to_file': False,
'base_url': 'http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.20/repos/centos6', 'action':
['create'], 'components': [u'HDP-UTILS', 'main'], 'repo_template': 'repo_suse_rhel.j2', 'repo_file_name':
'HDP-2.2.4.2', 'mirror_list': None}
> 2015-04-20 16:46:30,112 - u"File['/etc/yum.repos.d/HDP-2.2.4.2.repo']" {'content': Template('repo_suse_rhel.j2')}
> 2015-04-20 16:46:30,390 - Writing u"File['/etc/yum.repos.d/HDP-2.2.4.2.repo']" because
it doesn't exist
> 2015-04-20 16:46:30,697 - u"Repository['HDP-2.2.4.2']" {'append_to_file': True, 'base_url':
'http://public-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.2.4.2', 'action': ['create'],
'components': [u'HDP', 'main'], 'repo_template': 'repo_suse_rhel.j2', 'repo_file_name': 'HDP-2.2.4.2',
'mirror_list': None}
> 2015-04-20 16:46:31,236 - u"Package['kafka_2_2_*']" {'use_repos': ['base', 'HDP-UTILS-2.2.4.2',
'HDP-2.2.4.2']}
> 2015-04-20 16:46:32,549 - Installing package kafka_2_2_* ('/usr/bin/yum -d 0 -e 0 -y
install '--disablerepo=*' --enablerepo=base,HDP-UTILS-2.2.4.2,HDP-2.2.4.2 'kafka_2_2_*'')
> 2015-04-20 16:46:58,296 - u"Package['pig_2_2_*']" {'use_repos': ['base', 'HDP-UTILS-2.2.4.2',
'HDP-2.2.4.2']}
> 2015-04-20 16:46:59,212 - Installing package pig_2_2_* ('/usr/bin/yum -d 0 -e 0 -y install
'--disablerepo=*' --enablerepo=base,HDP-UTILS-2.2.4.2,HDP-2.2.4.2 'pig_2_2_*'')
> Can not install packages.
> Traceback (most recent call last):
>   File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line
97, in actionexecute
>     Package(name, use_repos=list(current_repo_files) if OSCheck.is_ubuntu_family() else
current_repositories)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 148,
in __init__
>     self.env.run()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
152, in run
>     self.run_action(resource, action)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
118, in run_action
>     provider_action()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py",
line 43, in action_install
>     self.install_package(package_name, self.resource.use_repos)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py",
line 51, in install_package
>     shell.checked_call(cmd, sudo=True, logoutput=self.get_logoutput())
>   File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70,
in inner
>     return function(command, **kwargs)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 82,
in checked_call
>     return _call(command, logoutput, True, cwd, env, preexec_fn, user, wait_for_finish,
timeout, path, sudo, on_new_line)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 199,
in _call
>     raise Fail(err_msg)
> Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install '--disablerepo=*' --enablerepo=base,HDP-UTILS-2.2.4.2,HDP-2.2.4.2
'pig_2_2_*'' returned 1. 
> Transaction Check Error:
>   installing package hadoop_2_2_4_2_2-2.6.0.2.2.4.2-2.el6.x86_64 needs 194MB on the /
filesystem
>   installing package hadoop_2_2_4_2_2-client-2.6.0.2.2.4.2-2.el6.x86_64 needs 194MB on
the / filesystem
> Error Summary
> -------------
> Disk Requirements:
>   At least 194MB more space needed on the / filesystem.
> 2015-04-20 16:56:24,794 - u"Package['kafka_2_2_4_2_2.noarch']" {'action': ['remove']}
> 2015-04-20 16:56:25,329 - Removing package kafka_2_2_4_2_2.noarch ('/usr/bin/yum -d 0
-e 0 -y erase kafka_2_2_4_2_2.noarch')
> 2015-04-20 16:56:27,067 - u"Package['zookeeper_2_2_4_2_2.noarch']" {'action': ['remove']}
> 2015-04-20 16:56:27,601 - Removing package zookeeper_2_2_4_2_2.noarch ('/usr/bin/yum
-d 0 -e 0 -y erase zookeeper_2_2_4_2_2.noarch')
> 2015-04-20 16:56:29,300 - Error while executing command 'actionexecute':
> Traceback (most recent call last):
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 214, in execute
>     method(env)
>   File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line
139, in actionexecute
>     raise Fail("Failed to distribute repositories/install packages")
> Fail: Failed to distribute repositories/install packages



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message