ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-10566) Ambari Upgrade from 1.7.0 to 2.0.0 fails to restart ZK server due to missing symlink
Date Mon, 20 Apr 2015 18:55:59 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-10566?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14503416#comment-14503416
] 

Hudson commented on AMBARI-10566:
---------------------------------

FAILURE: Integrated in Ambari-trunk-Commit #2374 (See [https://builds.apache.org/job/Ambari-trunk-Commit/2374/])
AMBARI-10566. Ambari Upgrade from 1.7.0 to 2.0.0 fails to restart ZK server due to missing
symlink (dlysnichenko) (dlysnichenko: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=7ad8c9acb5fdf27874d24ade5cbe38f1a59bba34)
* ambari-server/src/main/resources/common-services/ZOOKEEPER/3.4.5.2.0/package/scripts/zookeeper_server.py
* ambari-server/src/main/java/org/apache/ambari/server/controller/AmbariCustomCommandExecutionHelper.java
* ambari-server/src/main/resources/common-services/ZOOKEEPER/3.4.5.2.0/package/scripts/params_linux.py
* ambari-common/src/main/python/resource_management/libraries/script/script.py
* ambari-server/src/test/python/stacks/2.0.6/ZOOKEEPER/test_zookeeper_server.py
* ambari-server/src/main/resources/common-services/ZOOKEEPER/3.4.5.2.0/package/scripts/zookeeper.py


> Ambari Upgrade from 1.7.0 to 2.0.0 fails to restart ZK server due to missing symlink
> ------------------------------------------------------------------------------------
>
>                 Key: AMBARI-10566
>                 URL: https://issues.apache.org/jira/browse/AMBARI-10566
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>            Reporter: Dmitry Lysnichenko
>            Assignee: Dmitry Lysnichenko
>             Fix For: 2.1.0, 2.0.1
>
>         Attachments: AMBARI-10566.2.0.maint.2.patch, AMBARI-10566.2.0.maint.patch, AMBARI-10566.2.patch,
AMBARI-10566.patch
>
>
> Ambari upgrade from 1.7.0 to 2.0.0 had problems on starting/restarting zookeeper server
because /usr/hdp/current/zookeeper-server symlink was not found. The customer remedied the
issue by calling "hdp-select set zookeeper-server 2.2.3.0-###" on all of the hosts, which
created the symlink.
> In Ambari 1.7.0, ZK server was started using the libs from ZK client, so as part of the
Ambari Upgrade, we need to first call "hdp-select set zookeeper-server
> {version}
> "
> It's possible that the either exactly one of start/restart command will handle this.
Need to verify what the behavior is.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message