ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-10431) Don't do anything when ambari-server setup executed ONLY with -s
Date Fri, 10 Apr 2015 11:33:12 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-10431?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14489415#comment-14489415
] 

Hadoop QA commented on AMBARI-10431:
------------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12724532/AMBARI-10431.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:red}-1 core tests{color}.  The test build failed in ambari-server 

Test results: https://builds.apache.org/job/Ambari-trunk-test-patch/2302//testReport/
Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/2302//console

This message is automatically generated.

> Don't do anything when ambari-server setup executed ONLY with -s
> ----------------------------------------------------------------
>
>                 Key: AMBARI-10431
>                 URL: https://issues.apache.org/jira/browse/AMBARI-10431
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.1.0
>            Reporter: Vitaly Brodetskyi
>            Assignee: Vitaly Brodetskyi
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-10431.patch
>
>
> I have a question about 'ambari-server setup' command option '-s' - silent setup.
> When I do execute this first time it works as expected, but when I try to execute later
something like:
> 'ambari-server setup --database=mysql --databasehost=c6404 --databaseport=3306 --databasename=ambari
--databaseusername=ambari --databasepassword=bigdata --postgresschema=ambari -s'
> It will say: 'Nothing was done. Please, use ambari-server setup command without [ -s
] key, to change configuration'.
> Is this expected behavior? If it is, then we will have problems with ambari DB setup
in our tests.
> Because using command line arguments is much more easier and stable way to set DB properties,
then navigating through menu setup, because it behaves differently depending on OS type and
settings. This requires complex code to use text wizard in test code.
> Maybe there can be some option '-f' for example to tell ambari-server setup that it should
execute in silent mode even if it was already set up.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message